This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 37220 - the aumix-minimal loading doesnt work if sound isnt modular
the aumix-minimal loading doesnt work if sound isnt modular
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-23 13:05 EDT by Olivier Crête
Modified: 2014-03-16 22:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-23 13:05:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Olivier Crête 2001-04-23 13:05:54 EDT
If the sound driver is compiled in the kernel and not as a module, the
aumix-minimal loading is not run because it is inside the modules "if".

Putting it outside the "if" is the solution... The same error had been made
a few versions ago.. like in 6.0 I think....
Comment 1 Bill Nottingham 2001-04-23 14:13:08 EDT
Actually, it shouldn't be there at all. Thanks for reminding me, it will be removed
in 5.84-1.
Comment 2 Olivier Crête 2001-04-23 14:24:56 EDT
If it should be there at all, where are the mixer settings loaded then?
Comment 3 Bill Nottingham 2001-04-23 15:50:59 EDT
They should be loaded upon device registration; the cleanest way to
do that is with post-install scripts for modules.

Ideally, the modules should only be loaded on demand and there shouldn't
even be stuff in rc.sysinit for that, but ISA braindamage sort of requires
it.
Comment 4 Olivier Crête 2001-04-23 16:26:11 EDT
Is there such a script included in RH7.1 ? If so, where? (which packages?)
Comment 5 Bill Nottingham 2001-04-23 16:37:53 EDT
By post-install scripts for modules, I simply mean in modules.conf

post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L

Unfortunately, I don't think this works for the static case.
Comment 6 Olivier Crête 2001-04-26 11:58:22 EDT
I still believe that the right solution for the static case is for it to be in
the rc.sysinit. Putting before any sound module can be loaded will make sure
that it is just triggered in the static case.

Note You need to log in before you can comment on or make changes to this bug.