Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 372281 - no hard drives found by installer--unable to install
no hard drives found by installer--unable to install
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-09 03:32 EST by Glenn Sullivan
Modified: 2008-02-09 03:37 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-03 19:04:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Glenn Sullivan 2007-11-09 03:32:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.8) Gecko/20071022 Ubuntu/7.10 (gutsy) Firefox/2.0.0.8

Description of problem:
I have two physical drives connected to my computer--one is a SATA-150 Maxtor 200GB with 3 partitions and the second is a Maxtor 80GB USB external drive with one partition.  Neither drive was detected by Anaconda with the Fedora 8 dvd

Version-Release number of selected component (if applicable):
Fedora 8 DVD x86_64 installer

How reproducible:
Always


Steps to Reproduce:
1.put fedora dvd into dvd drive
2.reboot
3.choose the install or upgrade option
4.after about 5 minutes of loading drivers the installation comes to a screen where it tests the dvd
5.After test start Anaconda
6.choose language English
7.choose keyboard US layout
8.we are now at the partitioning screen and no hard drives are displayed.

Actual Results:
no hard drives are detected by Anaconda


Expected Results:
I would have liked to have installed Fedora 8

Additional info:
ASUS motherboard A8V-VM ultra
CPU AMD Athlon 64 X2 4200+ toledo
Maxtor internal 200GB SATA-150 drive
Maxtor external USB2.0 drive 80GB
Comment 1 Andre Robatino 2007-11-09 11:27:35 EST
  I have had the same problem since F7 came out, and the same thing still
happens with F8.  This is with very old (1999) hardware with a buggy BIOS,
though (see my bug #242766).  Your hardware is obviously much newer.  Did you
experience the same problem with F7 (assuming you  attempted installing it)?
Comment 2 Glenn Sullivan 2007-11-09 12:26:09 EST
I am currently have Fedora 7 on my machine--I did have to make a minor hardware
change--physically change out my DVD drive to something different to get it to
install.  Also all Fedora 7 kernels since 2.6.21-1.3194.fc7 give a kernel panic
error and locks up. I have tried 4 different versions of system BIOS on my
machine and all do the same thing--My machine comes with a flashable BIOS.

Northbridge: VIA K8M890
Southbridge: VIA VT8251
Comment 3 Andre Robatino 2007-11-09 12:41:28 EST
  If you already have an install DVD, you can use jigdo to create a Fedora Unity
CD set for the corresponding version with very little extra downloading - for
example, see

http://fedoraunity.org/news-archives/fedora-8-cd-sets-released

This sidesteps the problem with booting from DVD, assuming your drive can boot
properly from CD.  Of course, it doesn't help with the HD detection problem.
Comment 4 Chuck Ebbert 2007-11-09 18:28:21 EST
Possible workarounds for common problems are at:

https://fedoraproject.org/wiki/KernelCommonProblems

Things to possibly try for no disk drive found:

  pci=nomsi
  libata.dma=0
  clocksource=acpi_pm

And maybe others...
Comment 5 Christopher Brown 2008-02-03 19:04:07 EST
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

As this is an installer bug we are unable to resolve it for the Fedora 8 release
cycle. However as mentioned the Fedora unity project do release "re-spins" which
may resolve the problem for you.

Moving forward, Fedora 9 Alpha is released in a few days and if you are able to
test with this it would be greatly appreciated. If you are still unable to
install then please re-open and I will try and assist you in resolving it before
the final release. Thank you for taking the time to file the bug.
Comment 6 Andre Robatino 2008-02-09 03:37:07 EST
  I had the same problem with a single HD which was the primary master.  After
reading

http://forums.fedoraforum.org/showthread.php?p=959778

I changed the jumper from master to cable select, and now the HD is detected. 
Hope this helps.

Note You need to log in before you can comment on or make changes to this bug.