Bug 37233 - Normal users cannot start private apaches
Summary: Normal users cannot start private apaches
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: apache   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 51220 77703 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-23 17:59 UTC by Julio Sanchez Fernandez
Modified: 2007-04-18 16:32 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-21 10:00:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Julio Sanchez Fernandez 2001-04-23 17:59:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en]C-STL/0.3  (WinNT; U)


EAPI_MM_CORE_PATH is set to an absolute path (/var/run/httpd.mm.xxx) and cannot be overridden.

As a consequence, non-root users trying to start servers get a permission denied error.

This is not an unsurmountable problem in production use, but it is a major setback (that did not exist in prior versions) for development where it 
is common to have different users run their own servers.

The problem is described in the FAQ for mod_ssl at http://www.modssl.org/docs/2.8/ssl_faq.html#mmpath

Notice that the problem is nor avoided by not loading mod_ssl, the EAPI patch affects all configurations.

Reproducible: Always
Steps to Reproduce:
1.as a normal user, start apache as httpd -f /etc/httpd/conf/httpd.conf
2.
3.
	

Actual Results:  Apache does not start and shows the message:

Ouch! ap_mm_create(1048576, "/var/run/httpd.mm.14524") failed
Error: MM: mm:core: failed to open semaphore file (Permission denied): OS: No such file or directory

Comment 1 Nalin Dahyabhai 2001-07-24 19:18:44 UTC
The fix for this problem will be incorporated into a pending errata for Apache
1.3.20, and in Raw Hide.  In testing, it appears to default to creating the file
under [ServerRoot]/logs/, as it has previously.

Comment 2 Joe Orton 2004-09-21 10:00:55 UTC
Thanks for the report.  This bug is no longer present in the Apache
httpd 2.0 packages in Red Hat Enterprise Linux and Fedora Core.


Comment 3 Joe Orton 2004-09-21 10:07:12 UTC
*** Bug 51220 has been marked as a duplicate of this bug. ***

Comment 4 Joe Orton 2004-09-21 10:26:01 UTC
*** Bug 77703 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.