Bug 37234 - Bash profiles under gnome-terminal broken during upgrade
Bash profiles under gnome-terminal broken during upgrade
Status: CLOSED DUPLICATE of bug 20781
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-23 14:18 EDT by adam.huffman
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-19 13:42:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description adam.huffman 2001-04-23 14:18:54 EDT
In a text console a normal user still has all the aliases from
/etc/profile.d, for colorls etc.

Under X (via gdm), it seems that none of these files are used - the aliases
include only one I have added myself, there is no colorls etc.

A related(?) problem is that DEL does not delete the character under the
cursor in X (gnome-terminal), but it does on a text console and using rxvt
or xterm.
Comment 1 Michael Fulbright 2001-04-24 14:48:02 EDT
This is not an anaconda bug, reassigning.
Comment 2 Preston Brown 2001-07-19 13:24:12 EDT
Dave, this is the whole login shell issue, I believe.
Comment 3 Havoc Pennington 2001-07-19 14:23:37 EDT
The problem is that gnome-session clears the environment. 

I can't reproduce the delete key problem - if you open gnome-terminal preferences, 
you should have "Swap del/backspace" checked, "delete generates del" unchecked - 
those should be the defaults. Are your settings different?

Really the delete key thing needs to be a separate bug, see I am hosed now
because I need to resolve the login shell thing as a dup of #20781 but keep the
delete key bug open ;-)


*** This bug has been marked as a duplicate of 20781 ***
Comment 4 adam.huffman 2001-07-19 14:33:31 EDT
I've since installed the Ximian gnome packages, and the Delete problem is 
fixed.

However, I still have a problem with Home/End, which do not work when I run
mutt in a gnome-terminal, but do work in xterm, rxvt etc.  As I'm now running
the Ximian packages perhaps I should just file a separate bug report there.
Comment 5 Havoc Pennington 2001-07-19 14:57:41 EDT
Yes, please file the home/end thing with either Ximian or gnome.org - I recently 
filed it on gnome.org I think actually. I could be wrong. Anyway, if you filed
it here I would just close it and move it upstream. ;-)

Thanks!

Note You need to log in before you can comment on or make changes to this bug.