Bug 372451 - rt61pci is broken
rt61pci is broken
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-09 05:37 EST by Bohan
Modified: 2008-02-07 15:15 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.6.23.14-115.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-07 15:15:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output (25.36 KB, text/plain)
2007-11-14 17:15 EST, Bohan
no flags Details
ifconfig output (410 bytes, text/plain)
2007-11-14 17:16 EST, Bohan
no flags Details
iwconfig output (424 bytes, text/plain)
2007-11-14 17:20 EST, Bohan
no flags Details

  None (edit)
Description Bohan 2007-11-09 05:37:22 EST
Description of problem:

After booting Fedora-8-Live-X86_64, wireless cards based on the Ralink rt61
chipset are recognized, but all attempts to make a connection fail 

Version-Release number of selected component (if applicable):

Fedora-8-Live-X86_64

How reproducible:

Always

Steps to Reproduce:
1. Boot from Fedora-8-Live-X86_64 DVD, modprobe shows rt61pci is loaded, and the
rt61pci-firmware package is preinstalled on live media
2. Attempt to select a network using NetworkManager -> tries to connect but
cannot get a IP address
3. Install to hdd
4. Reboot
5. Try with NetWorkManager again -> same
6. Disable nm-applet and NetworkManager services
7. Reboot
8. Try setting up wlan0 using system-config-network with static IP, static ESSID
-> appears to connect, but can't ping router, can only ping itself
9. Try using iwconfig and ifconfig to manually bring the deveice up and
configure -> same
10. Download legacy rt61-cvs-daily driver from
http://rt2x00.serialmonkey.com/wiki/index.php/Downloads, compile and install
11. setup wlan0 with system-config-network -> working wireless
  
Actual results:

No working wireless

Expected results:

wireless card associates with access piont and can ping the access point

Additional info:

Tested on simple network with no encryption: D-Link DWL-g510 to Netcomm NB9W router.
Comment 1 José Matos 2007-11-09 11:46:21 EST
I think that this bug belongs to kernel (due to the wireless component) and 
not to an R language module. I am changing the component accordingly. :-)
Comment 2 John W. Linville 2007-11-09 14:24:12 EST
Please try these kernels (lots of rt2x00 updates):

   http://koji.fedoraproject.org/koji/buildinfo?buildID=23734

Do these work any better for you?
Comment 3 Bohan 2007-11-10 08:03:50 EST
How do I install alternative (2.6.23.1-49) kernel, kernel-devel and
kerel-headers alongside without overwriting the stable kernel (2.6.23.1-42)?
Comment 4 Bohan 2007-11-10 08:04:48 EST
sorry about the component mess, my first bug :)
Comment 5 Bohan 2007-11-11 02:36:57 EST
Running 2.6.23.1-49 now (it got pushed to updates), rt61pci is still broken.
The nasty thing is that that its appears to be working fine. i.e. you can scan
for networks and 'associate' with them. iwconfig then shows a valid SSID and
access point MAC, as well as a valid Link Quality, but no data is ever
transferred and the access point cannot be pinged.
Comment 6 John W. Linville 2007-11-12 11:53:33 EST
Please attach the output of running 'dmesg', 'ifconfig wlan0', and 'iwconfig 
wlan0'...thanks!
Comment 7 Bohan 2007-11-14 17:15:58 EST
Created attachment 259021 [details]
dmesg output
Comment 8 Bohan 2007-11-14 17:16:24 EST
Created attachment 259031 [details]
ifconfig output
Comment 9 Bohan 2007-11-14 17:20:43 EST
Created attachment 259041 [details]
iwconfig output

My wireless network details:

client distance: 6m
client: Dlink DWL-G510 Rev C2 (Ralink RT61)
typical link quality: 60 to 70%
SSID: kismet
encryption: open / none
access point: Netcomm NB9W C09_R10

Works well with legacy rt61 drivers from serialmonkey, but no luck with these
rt2x00 drivers
Comment 10 John W. Linville 2007-11-14 17:45:55 EST
Might I ask you to try a few earlier .fc8 kernels, to see if any of them are 
more stable w.r.t. wireless?

   http://koji.fedoraproject.org/koji/packageinfo?packageID=8

Which kernels work better?
Comment 11 Jon Stanley 2008-01-16 19:44:19 EST
Hello Bohan,

Have you had a chance to attempt the earlier kernels as stated in comment #10?
Comment 12 Bohan 2008-01-20 07:26:16 EST
Yes, I have tried about 5 other kernels from Koji, as well as ubuntu (2.6.22).
The problem in in the upstream srivers and there lack of backward compatibility
w.r.t older versions of the Devicescape wireless stack (it is developed against
2.6.24, where as f8 is 2.6.23). Leave this bug for now. We will see how things
go when 2.4.24 is released next month. Thanks to everyone vor helping
Comment 13 Bohan 2008-01-20 07:28:24 EST
By the way, the enhanced legacy drivers (CVS) for rt61 are stable and work well,
so peorple with Ralink rt61 cards are not really without wireless, but just have
to compile a driver.
Comment 14 John W. Linville 2008-01-21 08:35:08 EST
Bohan, just FYI -- the stack in Fedora kernels comes from the wireless-2.6 
tree (i.e. it is later than 2.6.23, current with upstream).  So if it is 
broken now it will continue to be so.

What is the latest Fedora kernel you have tried?  There have been some 
rt61-specific fixes merged fairly recently.
Comment 15 Bohan 2008-01-30 07:31:12 EST
I have just compiled a vanilla 2.6.24 kernel, copying over the Fedora 2.6.23
.config, and rt61pci is working!!!

I changed preemption to Preemptible Kernel(Low-latency desktop), enable 'Ralink
wireless drivers' in the network drivers section then compiled, rebooted and
wireless started working.

This is great news for F9!

Any chance 2.6.24 will be backported as an update for F8? (The rt2x00 srivers
require the latest ieee80211 stack, found only in 2.6.24 mainline)
Comment 16 John W. Linville 2008-01-30 10:39:55 EST
Please review comment 14 -- the wireless code in 2.6.24 is much older than 
what is already in the F8 kernels.

Please try these kernels:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=32986

If they continue to fail, please include new dmesg output as well 
as /var/log/messages and the output of 'lspci -n'.  Thanks!
Comment 17 John W. Linville 2008-02-07 15:15:11 EST
https://www.redhat.com/archives/fedora-list/2008-February/msg00803.html

Closing on basis of above message.  Please reopen if the problem persists with 
2.6.23.14-115.fc8.

Note You need to log in before you can comment on or make changes to this bug.