Bug 37255 - RH7.1 SMP will not boot on ASUS CUV4X-DLS motherboard after installation
RH7.1 SMP will not boot on ASUS CUV4X-DLS motherboard after installation
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Ingo Molnar
Brock Organ
:
Depends On:
Blocks: 37654
  Show dependency treegraph
 
Reported: 2001-04-23 15:56 EDT by Frank Bures
Modified: 2005-10-31 17:00 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-21 14:42:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Bures 2001-04-23 15:56:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.61 [en] (OS/2; U)


After sucessful installation of RH7.1 SMP, the machine would not reboot into SMP.  
It either crashes after:
ENABLING IO-APIC IRQs
... changing IO-APIC physical APIC ID to 2...ok
Synchronizing Arb IDs
..TIMER: Vector=49 pin1=2 pin2=0

or after this:

Warning: unexpected IO-APIC
calibrating APIC timer.....
...CPU clock speed is 1004.6878 MHz
...host bus clock speed is 133.9582 MHz
cpu:0, clocks:1339582, slice:446527
CPU0<T0:1339568, T1:893040, D:1, S:446527, C:1339582>

Reboot into single CPU mode works OK.

Reproducible: Always
Steps to Reproduce:
1.  Install RH7.1 on a ASUS CUV4X-DLS 2xCPU machine
2.  Reboot
3.  Reboot crashes.  The only way out is Reset.
	

Hardware:

ASUS CUV4X-DLS MoBo, 2xPIII/1GHz, 1GB RAM
Comment 1 Alan Cox 2001-04-23 16:08:32 EDT
I can confirm this is a known 2.4 problem. I don't currently know of a cure.
Comment 2 Arjan van de Ven 2001-04-23 16:11:14 EDT
Ingo: any ideas ?
Comment 3 Frank Bures 2001-04-24 07:54:16 EDT
Could you please let me know, when do you expect this bug to be resolved?
I have two machines that must go into production shortly.
If the bug is not going to be resolved in the near future, I will have to contact my supplier and ask him to
change ASUS MoBo's for TYAN.

Thanks
Comment 4 Frank Bures 2001-04-24 08:10:58 EDT
One more question:
Can I downgrade to 2.2.19 kernel?  Will it work with R7.1 distribution, or should I install RH7.0?
Comment 5 Arjan van de Ven 2001-04-24 08:13:26 EDT
All the configscripts and such are tuned to a 2.4 kernel. I would recommend
using 7.0 if you need a 2.2.19 kernel.
Comment 6 Ingo Molnar 2001-04-25 02:29:45 EDT
I dont know of any cure either, yet. It's tough to debug these sort of problems
remotely.

One suspect could be some sort of 32-bit overflow due to the high frequency of
the CPU - is it possible to somehow slow the CPU's speed down in the BIOS?

another thing to try would be to add printks to the boot code, to see exactly
where the lockup happens.

question: does the system boot the SMP kernel properly if you add numcpus=1 as a
boot option? It could be a startup problem of the second CPU.
Comment 7 Frank Bures 2001-04-25 13:34:29 EDT
The boot of the SMP  kernel with "numcpus=1" crashes exactly the same way as it does without it.
Comment 8 Frank Bures 2001-04-25 13:39:46 EDT
I tried to slow down the CPUs to 500MHz.  The crash was exactly the same "Unexpected IO-APIC".
Comment 9 Frank Bures 2001-04-26 07:30:34 EDT
I just tried to run at 800 MHz CPU's and 100 MHz bus.
The crash was the same. I do not believe it has anything to do with speed.
I am replacing the ASUS MoBo's with TYAN S2507 Tiger 230.  I will report the result.
Comment 10 Frank Bures 2001-04-26 11:02:32 EDT
TYAN S2507 Tiger 230 MoBo, though having the same chipset as ASUS, does _not_ have the problem.
2.4 SMP kernel booting and running just fine.
Comment 11 Arjan van de Ven 2001-04-26 11:07:23 EDT
This makes it _REALLY_ sound like a BIOS problem then.
Or the quality of wiring, you never know.
Comment 12 Need Real Name 2001-05-03 23:23:40 EDT
I have same problem with dual 600M P3s on an ASUS CUV4X-D with 1G. Why is this 
same hardware able to boot RH7.0 SMP 2.2 kernels but is unable to boot RH7.1 
SMP 2.4.2-2? I have tried nodma, noapm, nousb and numcpus=1 with no help. UP is 
OK.
Comment 13 Need Real Name 2001-05-04 01:18:36 EDT
Hey, I just compiled kernel 2.4.4 with SMP option and it works! dmesg looks a 
little different but I get "PCI_>APIC IRQ transform: (B1,I10,PO) -> 18" etc.
2.4.4 has the serial driver I am looking for, too. dmesg says "usb.c: 
registered a new driver hub" "found SMP MP-table at 000f5460" "Processors: 2"
and "WARNING: unexpected IO-APIC, please mail to linux-smp@vger.kernel.org". I 
don't see anything about DMA, what should I look for or did I loose this for 
IDE?
Comment 14 Need Real Name 2001-05-04 10:37:37 EDT
How bizarre. Last night I booted SMP kernel 2.4.4 twice and left it on 
overnight. This morning there's a blank screen but the monitor is still on full 
power and it won't wake up. I have to hold the power button in for a few 
seconds before it will shutoff the computer. Then it wouldn't boot SMP kernel 
2.4.4 the first few tries. Then it booted. I rebooted with noapm option, guess 
I'll see how well that takes.
Comment 15 Need Real Name 2001-05-04 10:37:40 EDT
How bizarre. Last night I booted SMP kernel 2.4.4 twice and left it on 
overnight. This morning there's a blank screen but the monitor is still on full 
power and it won't wake up. I have to hold the power button in for a few 
seconds before it will shutoff the computer. Then it wouldn't boot SMP kernel 
2.4.4 the first few tries. Then it booted. I rebooted with noapm option, guess 
I'll see how well that takes.
Comment 16 Alan Cox 2001-05-05 05:16:06 EDT
noapic might be a better option to try
Comment 17 Ingo Molnar 2001-05-06 05:33:19 EDT
please check whether 2.4.4 fixes the boot problem for everyone.
The 'hangs after a night' problem is likely an unrelated issue.
Comment 18 Need Real Name 2001-05-06 16:58:57 EDT
noapic cleans up alot while the MB BIOS is set to "Plug and Play OS = Y". Some 
of the SMP FAQ recommends "Plug and Play OS = N" and this is the fix I needed 
to get kernel 2.4.4 to boot cleanly and my soundcard is assigned to IRQ17 
(without noapic boot option). With noapic boot option the soundcard is assigned 
IRQ5. Kernel 2.4.4 has a .config option for the VIA VT82C* pci chipsets used on 
ASUS CUV4X-D and this will enable UDMA(100).
Comment 19 ajs 2001-07-30 14:50:05 EDT
For me, adding 'append="noapic"' to the smp kernel section of lilo.conf was
sufficient for everything to work with a stock RH 7.1 installation.

Tony
Comment 20 Jim Meyer 2001-08-09 16:45:04 EDT
SUCCESS! It appears that disabling MPS 1.4 in the motherboard's BIOS solves the
problem. As I went hunting for more info on this problem, I ran across this
message from LKML in March that may inform ...
http://www.cs.helsinki.fi/linux/linux-kernel/2001-10/0217.html
Comment 21 ajs 2001-08-28 19:41:19 EDT
Alternative workaround:

  If the secondary on-board IDE controlled is dissabled (Advanced->Chip Config)
then it is possible to boot both the 2.4.6-3.1smp (Roswell-1) and 2.4.7-2smp
(Roswell-2) kernels without appending 'noapic'.  I haven't tried the stock 7.1
kernel.

Note You need to log in before you can comment on or make changes to this bug.