Bug 37271 - Anaconda crashes with a backtrace after selecting upgrade
Summary: Anaconda crashes with a backtrace after selecting upgrade
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Brock Organ
URL:
Whiteboard: Yes This was part of a raid 1 system....
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-23 20:55 UTC by Tom Diehl
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-24 18:04:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Backtrace from the install (10.57 KB, text/plain)
2001-04-24 11:19 UTC, Tom Diehl
no flags Details
fdisk -l output (1.16 KB, text/plain)
2001-04-24 16:52 UTC, Tom Diehl
no flags Details

Description Tom Diehl 2001-04-23 20:55:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-ac3-1 i586)


When doing a text upgrade anaconda crashes with a backtrace. Doing a
graphical upgrade the machine just hangs. I saved the backtrace from  the
text install but I am not sure how to submit it to Bugzilla. I would prefer
not to copy it by hand.

Reproducible: Always
Steps to Reproduce:
1.Start anaconda with "text" at the lilo prompt
2.select us keymap, then 101 key keyboard
3.Select upgrade
	

Actual Results:  anaconda barfs and asks for a disk to copy the backtrace
to.

Expected Results:  Perform normal upgrade to completion

This is a stock RH 6.2 system with all applicable upgrades. The system is a
P3-600 with 1 20 Gig IBM drive and 256 Megs of memory

Comment 1 Brent Fox 2001-04-24 03:33:01 UTC
I know it's kind of a pain to enter it by hand, but without it, we don't really
have a way to debug it.

Comment 2 Tom Diehl 2001-04-24 11:19:40 UTC
Created attachment 16205 [details]
Backtrace from the install

Comment 3 Brent Fox 2001-04-24 16:08:44 UTC
Oh, it looks like you have some partitions on your system that used to be RAID
partitions...does this sound correct?  I have seen this bug before...the
installer is having trouble reading partition on hda5.  Can you tell me what
your existing partition table looks like?  Just run /sbin/fdisk -l /dev/hda as
root and post the output here.

Comment 4 Tom Diehl 2001-04-24 16:52:40 UTC
Created attachment 16245 [details]
fdisk -l output

Comment 5 Tom Diehl 2001-04-24 16:58:13 UTC
Yes it was part of a raid 1 installation. It was not stable so I broke it down.
The partitions are still marked as raid autostart. There is only 1 disk in the
machine. I do not see why it should matter to anaconda unless it is broken. It
does not seem to matter to anything else. :-). Oh well if you think it will help
I could change the partition type. FWIW hda5 is the root partition. I do not
have any of the md partitions in the fstab, they are all hdax.

Comment 6 Brent Fox 2001-04-24 18:04:50 UTC
In this scenario, the installer sees a RAID partition which has been orphaned.
That is, the installer cannot find the other RAID partitions that it is looking
for in order to upgrade.  Yes, this is a problem, but there's not much we can do
since there's no way of knowing where the other partitions have gone or how many
there were.  What you need to do is run fdisk and wipe that partition (or just
change the type) and things will work fine.  Please reopen this bug if this
doesn't solve the problem.


Note You need to log in before you can comment on or make changes to this bug.