Bug 37277 - After upgrading to kernel-2.2.19-7.0.1, Advansys ISA SCSI card and HP DDS2 tape no longer recognised
After upgrading to kernel-2.2.19-7.0.1, Advansys ISA SCSI card and HP DDS2 ta...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-23 19:12 EDT by Paul Gear
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-18 06:33:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Gear 2001-04-23 19:12:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.19-7.0.1 i686)


Under kernel-2.2.17-14, the following messages occur in syslog when i use
my tape drive:

Apr 24 08:38:44 gear02 kernel: scsi0 : AdvanSys SCSI 3.2M: ISA PnP 16 CDB:
BIOS C800, IO 110/F, IRQ 11, DMA 6
Apr 24 08:38:44 gear02 kernel: scsi : 1 host.
Apr 24 08:38:44 gear02 kernel:   Vendor: HP        Model: C1533A           
Rev: AN03
Apr 24 08:38:44 gear02 kernel:   Type:   Sequential-Access                 
ANSI SCSI revision: 02
Apr 24 08:39:43 gear02 kernel: st: bufsize 32768, wrt 30720, max buffers 5,
s/g segs 16.
Apr 24 08:39:43 gear02 kernel: Detected scsi tape st0 at scsi0, channel 0,
id 1, lun 0

Under 2.2.19-7.0.1, when i attempt the same thing i get this in syslog:

Apr 24 09:12:38 gear02 kernel: scsi : 0 hosts.

'modprobe advansys' shows this:

/lib/modules/2.2.19-7.0.1/scsi/advansys.o: init_module: Device or resource
busy
Hint: insmod errors can be caused by incorrect module parameters, including
invalid IO or IRQ parameters
/lib/modules/2.2.19-7.0.1/scsi/advansys.o: insmod
/lib/modules/2.2.19-7.0.1/scsi/advansys.o failed
/lib/modules/2.2.19-7.0.1/scsi/advansys.o: insmod advansys failed


Reproducible: Always
Steps to Reproduce:
1. Run on kernel 2.2.17-14
2. Access tape drive - works OK
3. Reboot on kernel 2.2.19-7.0.1
4. Attempt to access tape drive - error occurs
Comment 1 Paul Gear 2001-04-27 18:12:10 EDT
FYI, here is what my /proc/scsi/advansys/0 says when it is working:

AdvanSys SCSI 3.2M: ISA PnP 16 CDB: BIOS C800, IO 110/F, IRQ 11, DMA 6

Device Information for AdvanSys SCSI Host 0:
Target IDs Detected: 1, 7, (7=Host Adapter)
Host: scsi0 Channel: 00 Id: 01 Lun: 00
  Vendor: HP       Model: C1533A           Rev: AN03
  Type:   Sequential-Access                ANSI SCSI revision: 02

EEPROM Settings for AdvanSys SCSI Host 0:
 Serial Number: AE26A623A896
 Host SCSI ID: 7, Host Queue Size: 16, Device Queue Size: 4
 cntl ff00, no_scam 0
 Target ID:            0 1 2 3 4 5 6 7
 Disconnects:          Y Y Y Y Y Y Y Y
 Command Queuing:      N N N N N N N N
 Start Motor:          Y Y Y Y Y Y Y Y
 Synchronous Transfer: N N N N N N N N
 Host ISA DMA speed:   5 MB/S

Linux Driver Configuration and Information for AdvanSys SCSI Host 0:
 host_busy 0, last_reset 0, max_id 8, max_lun 8, max_channel 0
 unique_id 0, can_queue 16, this_id 7, sg_tablesize 50, cmd_per_lun 1
 unchecked_isa_dma 1, use_clustering 1, loaded_as_module 1
 flags 8, last_reset 0, jiffies 209a1f4
 queue_depth: 1:4

Linux Driver Statistics for AdvanSys SCSI Host 0:
 command 0, queuecommand 8, abort 0, reset 0, biosparam 0
 interrupt 9, callback 8, done 8
 exe_noerror 8, exe_busy 0, exe_error 0, exe_unknown 0
 build_error 0
 cont_cnt 8, cont_xfer 4.0 kb avg_xfer 0.5 kb
 Active and Waiting Request Queues (Time Unit: 100 HZ):
 target 1
   active: cnt [cur 0, max 1, tot 2], time [min 0, max 1, avg 0.5]
   waiting: cnt [cur 0, max 0, tot 0], time [min 0, max 0, avg 0.0]

Asc Library Configuration and Statistics for AdvanSys SCSI Host 0:
 chip_version 33, lib_version 118, lib_serial_no 121, mcode_date 12c3
 mcode_version 50d, err_code 0
 Total Command Pending: 0
 Command Queuing: 1:N
 Command Queue Pending: 1:0
 Command Queue Limit: 1:4
 Command Queue Full: 1:N
 Synchronous Transfer: 1:N
Comment 2 Jez Rogers 2001-07-23 12:56:31 EDT
This bug is present in kernel 2.2.19-7.0.8 RH7 also.
I have an Advansys ABP-510 ISA controller, but it is not (AFAIK) a PNP device.
My tape drive is different also, but that'ts irrelevant because I can't "insmod
advansys"
Comment 3 Paul Gear 2001-07-23 15:11:58 EDT
Upgrading to Red Hat 7.1 on the 2.4 kernel series solved this problem for me.
Comment 4 Paul Gear 2002-10-18 05:18:00 EDT
This bug can probably be closed, since it has worked on 7.1 and all subsequent
releases.

Note You need to log in before you can comment on or make changes to this bug.