Bug 372791 - brlcad need itcl to be in the ldpath to work
Summary: brlcad need itcl to be in the ldpath to work
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: itcl (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Wart
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 236856
TreeView+ depends on / blocked
 
Reported: 2007-11-09 14:35 UTC by Nicolas Chauvet (kwizart)
Modified: 2008-04-30 08:16 UTC (History)
0 users

Fixed In Version: 3.3-0.8.RC1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-03 01:30:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nicolas Chauvet (kwizart) 2007-11-09 14:35:59 UTC
Description of problem:
I'm trying to build brlcad which requires itcl (and itk) but as itcl insn't in
the ld path (/usr/lib64/itcl3.3 - same for /usr/lib64/itk3.3 ) I cannot rich it
without having to deal with obscure options (TCL_LIBRARY and or DYLD_LIBRARY_PATH ) 

Same problem for itclstub,  which is built statically (and it would be better to
have a shared build if possible...)
/usr/bin/ld: cannot find -ltclstub

Version-Release number of selected component (if applicable):


Actual results:


Expected results:


Additional info: for now i'm using theses options from brlcad:
(and it work better if i had itck and itk path in /etc/ld.so.conf.d )
But it is missing itclstub and itkstub....

export ITCL_LIBRARY=%{_libdir}/itcl3.3/
export ITK_LIBRARY=%{_libdir}/itk3.3/
sh %{_libdir}/itclConfig.sh
%configure \
....
  --with-libs="-L%{_libdir}/itcl3.3/ -L%{_libdir}/itk3.3/"

Comment 1 Wart 2007-11-10 06:08:04 UTC
Just a heads up that I'll be mostly offline for the next week.  I won't be able
to respond properly to this bug report until at least Nov. 17.

Comment 2 Wart 2007-12-20 00:50:17 UTC
I'm taking a look at the brlcad and itcl/itk packages now to see how to
reconcile this issue.  I'll post again when I have more information.

Comment 3 Wart 2007-12-20 02:05:49 UTC
Indeed, the itcl and itk shared libraries need to be moved to /usr/lib{64}/. 
I'll build an update for each shortly.

As for the stub library, the purpose of this library is to serve as a portable
shared lib loader for Tcl libraries; it doesn't make any sense at all to build
it as a shared library.  See http://wiki.tcl.tk/285 for more information on Tcl
stub libraries.  It looks to me like brlcad only links against the libitcl3.3.so
shared library and doesn't use the stub library anyway.  Is that true?

Comment 4 Fedora Update System 2007-12-21 21:10:18 UTC
itk-3.3-0.8.RC1.fc8, itcl-3.3-0.11.RC1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update itk itcl'

Comment 5 Nicolas Chauvet (kwizart) 2007-12-21 23:07:56 UTC
Thx for working on this...
Note that since i'm out access from my build system, I will not be able to test
brlcad build until next wednesday (26/12).

A agree about the stub library. (meant to be portable - so unuseful for our
purpose).

The problem that remains with brlcad is mged (the main program) that fails to
initialize tcl/tk for unknow reason (patched ictl/itk). I expect some env
variables to be unset or some file/directory path that has moved and was
inproperly hardcoded...

Anyway i will test this when i will be back. I expect that it would be useful to
have all the tcl/tk entire framework to be rebuilt against tcl/tk 8.5 (for now
brlcad has a patch that lower the requirement to tcl/tk 8.4. As such it is more
targeted to be a F-9 only Review...

Again thx for taking care of that...

Comment 6 Fedora Update System 2008-01-03 01:30:17 UTC
itk-3.3-0.8.RC1.fc8, itcl-3.3-0.11.RC1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Nicolas Chauvet (kwizart) 2008-04-30 07:52:46 UTC
Sorry, I forgot to update this bug.
brlcad build fine with the current itcl itk in rawhide.
Others problem with detecting itcl/itk are brlcad side and telling them at
%configure time solve things.

Comment 8 Nicolas Chauvet (kwizart) 2008-04-30 08:16:15 UTC
I forgot to say that this path seems wrong to me (F-9 case)
 %{_libdir}/itclConfig.sh
it should be %{tcl_sitearch}/itclConfig.sh (where most others are)
At least i'm not sure to understand this point very well according to :
http://fedoraproject.org/wiki/Packaging/Tcl

Anyway it's work fine like this...




Note You need to log in before you can comment on or make changes to this bug.