Bug 37284 - Quake3 won't work, other 3d games do though
Summary: Quake3 won't work, other 3d games do though
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 7.1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-24 01:02 UTC by Casey Clemens
Modified: 2007-04-18 16:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-11 03:19:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log of XFree86 (24.13 KB, application/octet-stream)
2001-04-25 00:22 UTC, Casey Clemens
no flags Details
Config-4 file (3.63 KB, application/octet-stream)
2001-04-25 00:23 UTC, Casey Clemens
no flags Details

Description Casey Clemens 2001-04-24 01:02:01 UTC
Both Quake 3 Arena and Decent 3 from loki games do not work. I also have 
Soldier of Fortune, but it works fine. When I start the game in KDE 
2.1.1, the screen will flicker for a few seconds, and then XFree86 will 
shut down, and I will end up at the login screen. I am running Red Hat 
7.1 on a Pentium 3 550 mhz, 128 RAM, Voodoo3 3500 video card, 
Soundblaster Live card.

Comment 1 Casey Clemens 2001-04-25 00:22:09 UTC
Created attachment 16306 [details]
Log of XFree86

Comment 2 Casey Clemens 2001-04-25 00:23:22 UTC
Created attachment 16307 [details]
Config-4 file

Comment 3 Mike A. Harris 2001-05-07 11:28:49 UTC
Several notes:

Your config file appears to have been edited in a non UNIX text editor such
as NOTEPAD in Windows.  Solution: do not do that.  DOS/Windows text editors
_will_ corrupt any UNIX text files, config files, or shell scripts you edit
with them.  Just use a standard UNIX editor if you need to edit the files.

Xconfigurator --preferxf4 will give you a new config file to work with.

2) When attaching files to bug reports, please choose the proper attachment
type.  Your files were not easily viewable in the web browser because they
were application/octet-stream (a binary file) instead of text/plain.  Please
mark config files and any other text files as text/plain to ease bug report
handling.  Thanks in advance.  ;o)

3) It appears you have multiple video cards in your machine.  Try the Voodoo
card alone and see if that fixes things.  If not, please try upgrading to
the XFree86 found at:  ftp://people.redhat.com/mharris/testing/

It contains many tdfx driver fixes.  Does it fix the problem for you?

Comment 4 Mike A. Harris 2001-05-11 03:18:35 UTC
So does the updated XFree86 I mentioned fix the problem for you?

Comment 5 Mike A. Harris 2001-08-08 12:47:00 UTC
No response...
closing bug report due to lack of feedback.

Suggestions: Make sure motherboard BIOS is flashed to latest from
vendor to ensure VIA bugfixes are present.  You need to run the
Voodoo 3 in 16 bit depth, and in 1024x768 or less to do DRI properly.



Note You need to log in before you can comment on or make changes to this bug.