Bug 37286 - 7.0 boot floppy incompatible with 2.2.19-7.0.1 kernel
7.0 boot floppy incompatible with 2.2.19-7.0.1 kernel
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-23 21:20 EDT by redhat-bugs
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-09 16:09:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description redhat-bugs 2001-04-23 21:20:31 EDT
Not really anaconda but there is no catagory for "install floppy".

When you upgrade a kickstart server to the 2.2.19-7.0.1 kernel, kickstart
floppies no longer work.  This is due to a compatibility between the v2/3
NFS in 2.2.19-7.0.1 and the "mount" command on the boot floppy.

It can be worked around by forcing the rpc.mountd on the server into v2
only mode however this is less than desirable if your kickstart servers is
a general purpose NFS server.
Comment 1 Michael Fulbright 2001-04-24 14:46:56 EDT
Are you saying the default nfs behavior of a system with the 2.2.19 kernel is
different than from how it would act with the kernel shipped in 7.0?

Michael do you know of anything different with NFS in this context?
Comment 2 redhat-bugs 2001-04-24 16:35:19 EDT
That's exactly what I am saying.  :-)  The 2.2.19-7.0.1 kernel and
nfs-utils-0.3.1-7 default to v2 and v3 NFS.  The 2.2.16-22 kernel (and related
nfs-utils) was v2 only.  This difference is not normally a problem *except* for
the "mount" command shipped on the RH 7.0 boot/install diskette.  It would seem
that it cannot handle the responses from the new rpc.mountd in the new
kernel/nfs-utils combo.
Comment 3 Brent Fox 2001-05-01 16:09:37 EDT
Do you see this problem with Red Hat Linux 7.1?
Comment 4 redhat-bugs 2001-05-01 19:55:14 EDT
It would seem that the "lang" and "keyboard" parameters of the kickstart .cfg
file have changed as I get prompted for them on the 7.1 install floppy when I
didn't on the 7.0 install floppy.

However I think the answer you are looking for is yes, the 7.1 boot floppy can
mount from an NFS server running the 2.2.19-7.0.1 kernel and updated nfs-utils
without having to force the rpc.mountd on the server into v2 mode.

I am thinking that knowing this gives you an idea of what needs to be done to
the 7.0 boot floppy to make it work with NFS v3 no?
Comment 5 Brent Fox 2001-05-09 16:09:00 EDT
No, the parameters for land and keyboard did not change between 7.0 and 7.1.  I
can't spend time tweaking the 7.0 boot disks at this point.  Resolving as
'Current Release' since the 7.1 boot disks work ok.

Note You need to log in before you can comment on or make changes to this bug.