Bug 373201 - No audio out on MacBook Pro (SantaRosa ICH8)
No audio out on MacBook Pro (SantaRosa ICH8)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.1
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Jaroslav Kysela
Red Hat Kernel QE team
:
Depends On: 525390
Blocks: 533192 526948
  Show dependency treegraph
 
Reported: 2007-11-09 12:27 EST by Craig Chaney
Modified: 2010-05-14 04:40 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 483594
Environment:
Last Closed: 2010-05-14 04:40:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
scsconfig.log the audio tool said to attach (50.49 KB, text/plain)
2007-11-09 12:28 EST, Craig Chaney
no flags Details
scsrun.log file the error dialog said to attach. (293 bytes, text/plain)
2007-11-09 12:29 EST, Craig Chaney
no flags Details

  None (edit)
Description Craig Chaney 2007-11-09 12:27:53 EST
Description of problem:
I have no audio output when running the audio configuration (or any other time).
I have verified the audio device is not muted through alsamixer as well as the
volume is at a reasonable level.

Version-Release number of selected component (if applicable):


How reproducible:
Every time.

Steps to Reproduce:
1.Run the audio configuration tool
2.Play the test audio button
3.Change PCM devices to test all
  
Actual results:


Expected results:


Additional info:
I am running an Apple MacBook Pro (SantaRosa ICH8) which seems to be properly
identified.
Comment 1 Craig Chaney 2007-11-09 12:28:54 EST
Created attachment 253071 [details]
scsconfig.log the audio tool said to attach
Comment 2 Craig Chaney 2007-11-09 12:29:33 EST
Created attachment 253081 [details]
scsrun.log file the error dialog said to attach.
Comment 3 Brian Maly 2007-12-13 20:21:11 EST
Does the raw device (rather than the audio tools) work? 
I.e, do you hear any noise if you run "find / > /dev/audio"?

Also could run "/sbin/lsmod|grep snd" and attach the output?
Comment 5 Stewart Adam 2008-05-07 16:57:48 EDT
I can confirm this on a MacBook Pro 4,1. Fixed by adding the model=mpb3 to the
snd-hda-intel options.
Comment 6 Stewart Adam 2008-08-31 20:45:15 EDT
Any updates on this issue?
Comment 8 RHEL Product and Program Management 2009-04-23 13:49:13 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 11 Jaroslav Kysela 2009-10-07 08:40:32 EDT
The latest ALSA HDA intel driver has this change. Backport bug#525390 .
Comment 12 RHEL Product and Program Management 2009-10-07 09:00:10 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 13 Jaroslav Kysela 2009-11-05 05:43:06 EST
The latest ALSA HDA driver for RHEL 5.5 is available here:

http://people.redhat.com/~jkysela/RHEL5/

Please, report back test results.
Comment 16 RHEL Product and Program Management 2009-12-16 01:11:33 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 20 Jaroslav Kysela 2010-05-14 04:40:40 EDT
I believe that this issue is fixes in RHEL 5.5. If the problem persists, please, reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.