Bug 373471 - yum secretly adds repo urls which aren't under /etc/yum.repos.d
yum secretly adds repo urls which aren't under /etc/yum.repos.d
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
8
All Linux
high Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-09 14:17 EST by Don Zickus
Modified: 2014-01-21 18:00 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-12 11:31:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Don Zickus 2007-11-09 14:17:00 EST
Description of problem:
So I did a fresh install of F8 on my laptop from qafiler (as pointed out by
Warren).  I booted my machine, pirut started and updated my box, and I shutdown
the machine.  

I brought the machine home, fired off a yum install <foo> and it failed to find
download.boston.redhat.com.  Now nowhere did I ever enter the address during my
install.  Even a 'grep -r boston /etc/*' yielded nothing (except dhcpclient).

How the hell??!!  Anyway a 'yum install --disablerepo=* --enablerepo=f* <foo>'
works around the issue.  I have no idea why.


Version-Release number of selected component (if applicable):
fresh install of F8

How reproducible:
everytime

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Seth Vidal 2007-11-09 14:24:02 EST
Do you have any:
mirrorlist= lines?

the mirrorlists are handed back based on the best ones for your ip.

this is not a bug
Comment 2 Don Zickus 2007-11-09 15:06:06 EST
that's bs.

I changed IP addresses as I went from the company network to my home network.

If yum can't handle that through mirrorlists than that's a bug in of itself.

Regardless, I do have mirrorlist= lines (but none of the contain *boston*

ps sorry for being grumpy.  just sucks to install a laptop and have so many
issues.  ;-)
Comment 3 Seth Vidal 2007-11-09 15:13:19 EST
you changed networks but the mirrorlists were still cached. So yum used the
within-cache-expiration mirrorlists rather than grab new ones. Your old ones
were for the boston office's vpn only.

There's the problem.

yum can handle changing networks fine - but it has no way of knowing that your
successfully cached mirrorlist is incorrect on this network.

Comment 4 Don Zickus 2007-11-09 15:20:06 EST
should it cache the ip address with the mirrorlist? that way if the ip address
changes it can invalidate the mirrorlists?
Comment 5 Seth Vidal 2008-03-12 11:31:01 EDT
No, Set your mirrorlist_expire variable to a smaller number.
Comment 6 Don Zickus 2008-03-12 12:05:52 EDT
I assume 'mirrorlist_expire' is supposed to be in /etc/yum.conf?  If it is, I
don't have a variable nor value to set smaller.

Also any way to make this problem more obvious to the casual user so they don't
scratch their head and file bugzillas? :-)
Comment 7 Seth Vidal 2008-03-12 12:14:35 EDT
man yum.conf

it's in there on mine.

The casual user doesn't have a separate mirror at work than the ones at home.

Note You need to log in before you can comment on or make changes to this bug.