Bug 373481 - New user creation through rhn_register results in error.
New user creation through rhn_register results in error.
Status: CLOSED WORKSFORME
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend (Show other bugs)
rhn500
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bryan Kearney
Red Hat Satellite QA List
:
Depends On:
Blocks: 253916
  Show dependency treegraph
 
Reported: 2007-11-09 14:18 EST by Preethi Thomas
Modified: 2013-01-10 04:16 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-13 15:02:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2007-11-09 14:18:19 EST
Description of problem:
New user creation through rhn_register results in error.

Version-Release number of selected component (if applicable):
Red Hat Network release 5.0.4

How reproducible:
always

Steps to Reproduce:

1. Run rhn_register on a Rhel 4.6 system
2. Enter a new username / password
3. Enter the email address.
4. Click next.
5. At the new user information screen, click next with or without entering any
information.

Actual results:
An error has occurred:
xmlrpclib.Fault
See /var/log/up2date for more information
You have new mail in /var/spool/mail/root

Expected results:
User gets created without any error.


Additional info:
/var/log/up2date

 up2date   File "/usr/sbin/rhn_register", line 1273, in ?
    sys.exit(main() or 0)
   File "/usr/sbin/rhn_register", line 728, in main
    tui.main()
   File "/usr/share/rhn/up2date_client/tui.py", line 1296, in main
    tui.run()
   File "/usr/share/rhn/up2date_client/tui.py", line 1244, in run
    win.saveResults()
   File "/usr/share/rhn/up2date_client/tui.py", line 438, in saveResults
    self.tui.other['channel'] = self.channelList.current()
   File "/usr/lib/python2.3/site-packages/snack.py", line 97, in current
    return self.key2item[self.w.listboxGetCurrent()]
Comment 1 James Bowes 2007-11-29 13:29:12 EST
This was caused by bad data. Preethi, is it ok to close this one?
Comment 2 Preethi Thomas 2008-02-05 10:31:15 EST
sure.

Note You need to log in before you can comment on or make changes to this bug.