Bug 373511 - scsi_reserve should leave fence domain upon failure
scsi_reserve should leave fence domain upon failure
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cman (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Ryan O'Hara
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-09 14:25 EST by Ryan O'Hara
Modified: 2009-04-16 19:00 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2008-0347
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:58:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ryan O'Hara 2007-11-09 14:25:58 EST
When an error occurs during scsi_reserve startup, it should immediately force
the node to leave the fence domain. An error means that we are unable to
register with one or more device, and therefore our node is not fully capable of
performing a fence operation. Furthermore, it is desirable to force the node to
leave the fence domain since this will prevent it from being able to mount to
filesystem, which should not be allowed if the node cannot register with the
devices.
Comment 2 RHEL Product and Program Management 2008-01-07 15:45:16 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Ryan O'Hara 2008-01-18 18:15:17 EST
Fixed. This will prevent users from being able to mount the filesystem if
scsi_reserve encounters any errors during startup. If an error occurs, this
would indicate that the node was unable to register with one or more of the
devices in the cluster volumes(s). If registrations are not created, then we
must prevent this situation since their would be no way to fence the node
if/when needed.

Fix will check if any errors occurred during startup. If an error did occur
while registering with a device, script calls 'fence_tool leave' and logs a
message. Note that you cannot mount the filesystem if you are not in the fence
domain. This is desirable.
Comment 6 errata-xmlrpc 2008-05-21 11:58:21 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0347.html

Note You need to log in before you can comment on or make changes to this bug.