Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 3736 - Host name resolution conflict
Host name resolution conflict
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: nmh (Show other bugs)
5.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-06-25 16:08 EDT by Dan Yocum
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-07-07 14:19:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Yocum 1999-06-25 16:08:13 EDT
There is a host name resolution conflict in either nmh or
ypbind or sendmail or how the /etc/nsswitch file is set up
on (at least) standard Red Hat 5.2 and probably other
versions. It's your choice which is really the culprit :).

The problem manifests itself when attempting to resolve the
machine name of the local machine when sending mail through
exmh.  If the following line is present in the /etc/hosts
file, then sendmail bombs with the classic "we do not relay"
message:

127.0.0.1	localhost.localdomain	localhost

This is different than the Red Hat standard where the
nickname and fully qualified name are switched.

The reason is, nmh resolves to the first name, but of
course, sendmail says, I don't know that machine name (I
only know localhost), and bombs.

So, why do I have it in this order?  Because ypbind needs it
this way (at least generically).  ypbind requires the fully
qualified name in order to authorize remote hosts to
connect.

In any case, that's the problem.  Good luck.

Dan
Comment 1 Jeff Johnson 1999-06-26 10:41:59 EDT
Have you tried adding localhost.localdomain to /etc/sendmail.cw?
That should stop sendmail from squawking.

I'm also not sure why you think that the line in /etc/hosts must
have localhost.localdomain first in order for ypbind to work. This
appears to be a configuration issue, not a Red Hat distribution
problem.
Comment 2 Anonymous 1999-07-06 13:52:59 EDT
It's not necessarily that the ypserver wants to see
localhost.localdomain (sorry 'bout the confusion), but rather the
fully qualified machine name(e.g., sapphire.fnal.gov) instead of the
nickname (e.g., sapphire). Our Sun and IRIX yp servers get awful
confused when they see the nickname first instead of the fully
qualified machine names when trying to do the reverse name lookup to
authorize remote logins.  So, to keep things consistent, I also put
the localhost.localdomain entry first in /etc/hosts.

I'll try the sendmail fix as well; maybe this should also be added to
the default Red Hat sendmail.cw in the future?

Cheers,
Dan

Note You need to log in before you can comment on or make changes to this bug.