Bug 373601 - Failed logins not reported correctly
Failed logins not reported correctly
Status: CLOSED DUPLICATE of bug 331141
Product: Fedora
Classification: Fedora
Component: NetworkManager-vpnc (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-09 14:58 EST by Don Zickus
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-27 10:10:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Don Zickus 2007-11-09 14:58:22 EST
Description of problem:
I don't feel like filing individual bugs for all the problems I found so I list
them here because I'm lazy

1 - if my username and vpnc username are different and I forget to check the
little box that allows me to change it, I'm screwed.  No way to know it failed
or why it failed.  

2 - logging into vpnc takes foooorrreeeeevvveeer.  It's faster to run the
command line script and hand edit the /etc/resolv.conf file than it is to wait
for the gui to finish.

3 - what is with the error 'VPNC software not found'??  How is that supposed to
trigger my memory to yum install NetworkManager-vpnc and re-run the vpnc setup
on NetworkManager

Version-Release number of selected component (if applicable):
NetworkManager-vpnc-0.7.0-0.4.svn3030.fc8

How reproducible:
reliably

Steps to Reproduce:
1.create user account with different vpnc username
2. forget to tell that to the vpnc config file
3. connect
4. wait foooorrrreeeeevvvveeeer
5. scratch your head after 10 minutes wondering if you are connected or not

  
Actual results:
ugh

Expected results:
yeah!

Additional info: i hate filing bzs
Comment 6 Denis Leroy 2007-11-21 08:17:08 EST
1.  There are issues reporting failed login errors, I'll look into that. As for
not telling you about the wrong username, that's very much the expected
behavior. Ssh wouldn't tell you if you used the wrong username.

2. I have no idea why. It's not that slow for me.

3. "no suitable vpn software found on your system". that doesn't trigger your
memory to instal it ? Granted, it could include buttons to the appropriate pirut
install commands, or something like that.

Comment 7 Don Zickus 2007-11-21 10:29:28 EST
Commenting in regards to

1.  I understand ssh won't tell me that.  But it does tell that it failed.  What
I was hoping to see or would like to suggest is, upon such failures a little
window pops up (much like the succesful-connection window) that states
  - the user was unable to connect
  - displays the username@machine (to allow the user to easily see typos)
  - suggest a possible reason or three why this happened and what the user
should double check

  The silent failure and forgetting that I had a different username were the
causes of my frustration.  Some failure messages would allow me to quickly see
that I was an idiot.  This would have also helped a co-worker resolve his
problem instead of walking around stating the NetworkManager is still broken on
F7 and he will try F8.

2. I don't have anything to suggest for this.  I was just reporting a 'feel' for
how things were working for me.  Not sure how you want to handle that.

3. Actually believe it or not, no it doesn't trigger my memory.  The reason why
is because I didn't know _what_ to install.  Luckily I have some 'yum kungfu'
and a quick search revealed the networkmanager-vpnc rpm.  But if Grandma wanted
to vpn into her Cookie Baking Business, I'm not sure she would be able to figure
it out.  Like you said perhaps a suggestion would help out.


Granted these issues aren't really *technical* problems, but more along the line
of *usability* issues.  To me the big reason why Ubuntu is doing as well as they
are, is the fact they are trying to iron out the usability problems.  Fedora has
this legacy of being a *geek's* toy.  

Now I don't mean to pick on nm-vpnc about this (I picked on yum too a little). 
A lot of packages have these issues, I just happened to run into nm-vpnc first
because it was important to me.

I hope this helps.

Cheers,
Don
Comment 8 Denis Leroy 2007-11-27 10:10:27 EST
There's already a bug filed for the failed logins not reported correctly, so
I'll close this. The other issues would be better reported upstream directly.


*** This bug has been marked as a duplicate of 331141 ***

Note You need to log in before you can comment on or make changes to this bug.