Bug 373611 - network install fails with airo wireless
network install fails with airo wireless
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-09 15:08 EST by Paul Jenner
Modified: 2008-08-02 19:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-13 15:03:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Jenner 2007-11-09 15:08:16 EST
Description of problem:

Network install not possible with airo wireless. Returns immediately to the
install media selection screen when http or ftp are selected. The console log
indicates that Anaconda is not recognising the airo device as a network device.
Excerpt from console log:

INFO - modules to insert airo XXX YYY
INFO - loaded airo from modules/modules.cgz
INFO - inserted /tmp/airo.ko
INFO - need to set up networking
INFO - going to pick interface
CRITICAL - no network device in chooseNetworkInterface

Version-Release number of selected component (if applicable):
F8 boot.iso

How reproducible:
Always

Steps to Reproduce:
1. boot F8 boot.iso CD on PC with PCI airo wireless NIC 
2. choose install or upgrade
3. follow to the install media selection screen and choose http or ftp
  
Actual results:
Returns to install media selection screen immediately

Expected results:
Network install continues using airo network device

Additional info:
Not tried on machines with other network cards yet (wireless or wired) - will
try that next
Comment 1 Jeremy Katz 2007-11-12 13:51:13 EST
By default we skip wireless devices -- does it work if you add 'allowwireless'
to the kernel parameters?
Comment 2 Paul Jenner 2007-11-13 15:03:12 EST
Passing 'allowwireless' worked - Anaconda accepts HTTP media type selection and
goes on to request wireless network details.

Apologies - I should have found that myself in docs or code.

Wireless network is then not working for me but that is another story and I
expect a local issue :-)

Note You need to log in before you can comment on or make changes to this bug.