Bug 373741 - oops on second CIFS mount to server when null auth is used
Summary: oops on second CIFS mount to server when null auth is used
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 5.1
Hardware: All
OS: Linux
low
low
Target Milestone: ---
: ---
Assignee: Jeff Layton
QA Contact: Martin Jenner
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-09 20:45 UTC by Jeff Layton
Modified: 2008-05-21 15:01 UTC (History)
2 users (show)

Fixed In Version: RHBA-2008-0314
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 15:01:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch -- fix oops when null auth is used on second cifs mount to same server (1.46 KB, patch)
2007-11-09 20:45 UTC, Jeff Layton
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0314 normal SHIPPED_LIVE Updated kernel packages for Red Hat Enterprise Linux 5.2 2008-05-20 18:43:34 UTC

Description Jeff Layton 2007-11-09 20:45:33 UTC
Easily reproducible oops -- set up a CIFS share with anonymous auth. fstab entry
something like this:

//host/public /mnt/cifspub    cifs    guest,sec=none,noauto   0 0

...mount it, and then try to mount it again. The second mount attempt will cause
an oops.

Attached patch has been sent upstream, but has not been committed yet.

Comment 1 Jeff Layton 2007-11-09 20:45:33 UTC
Created attachment 253411 [details]
patch -- fix oops when null auth is used on second cifs mount to same server

Comment 2 RHEL Product and Program Management 2007-11-13 21:35:40 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 3 Jeff Layton 2007-12-17 12:17:33 UTC

*** This bug has been marked as a duplicate of 417961 ***

Comment 4 Jeff Layton 2007-12-20 20:22:23 UTC
Unduping bug since I posted a patch with this BZ number.

Comment 5 Don Zickus 2007-12-21 20:18:29 UTC
in 2.6.18-62.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5

Comment 8 errata-xmlrpc 2008-05-21 15:01:25 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0314.html



Note You need to log in before you can comment on or make changes to this bug.