Bug 373821 - Dell Inspiron 6400 fails to hibernate due to inability to write to disk
Dell Inspiron 6400 fails to hibernate due to inability to write to disk
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-09 16:17 EST by Bojan Smojver
Modified: 2008-02-03 23:09 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.6.23.8-63.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-03 23:09:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -vv from the notebook that fails hibernation (15.79 KB, text/plain)
2007-11-09 16:19 EST, Bojan Smojver
no flags Details
dmesg from the notebook that fails hibernation (21.84 KB, text/plain)
2007-11-09 16:19 EST, Bojan Smojver
no flags Details
lspci -vv from the notebook that doesn't fail hibernation (15.79 KB, text/plain)
2007-11-09 16:21 EST, Bojan Smojver
no flags Details
dmesg from the notebook that doesn't fail hibernation (31.99 KB, text/plain)
2007-11-09 16:22 EST, Bojan Smojver
no flags Details
Error as seen from run level 3 after running pm-hibernate (206.78 KB, image/jpeg)
2007-11-09 19:30 EST, Bojan Smojver
no flags Details
End of dmesg output (sorry, more/less would not work - I/O error) (209.44 KB, image/jpeg)
2007-11-09 19:31 EST, Bojan Smojver
no flags Details
lspci-vv (15.83 KB, text/plain)
2007-11-12 06:16 EST, SJM
no flags Details
excerpt of lspci -vv and dmesg for ICH7 SATA controller (2.26 KB, text/plain)
2007-11-15 14:11 EST, Paul Stewart
no flags Details

  None (edit)
Description Bojan Smojver 2007-11-09 16:17:03 EST
Description of problem:

With upgrade to F8, one of my Dell Inspiron 6400 notebooks fails to hibernate
with errors related to writes to disks (along the lines of: unable to write to
swap, EXT3-fs unable to write etc.). The weird bit is that my other Dell
Inspiron 6400 (which has a slightly different configuration) has no problems
whatsoever. My best guess is that this difference is what's causing the problem.


Version-Release number of selected component (if applicable):
2.6.23.1-42.fc8

How reproducible:
Always.

Steps to Reproduce:
1. Boot F8 on this notebook.
2. Attempt to hibernate.
3. Watch it print endless messages about inability to write to disk.
  
Actual results:
Fails to hibernate.

Expected results:
Worked fine under F7 with all the updates (i.e. kernel 2.6.31.1-21).

Additional info:
I'm using the "combined_mode=libata" boot option to enable good performance on
CDRW drive.

Upgrade to latest Koji kernel (-49) doesn't fix the problem. The only difference
is that the machine remounts ext3 file systems read only and then goes back to X
(i.e. one can see the mouse pointer), which is, of course, unusable, because all
file systems are mounted read only. Ditto logging into one of the text consoles.
The only option is to turn the system off.

Repeated fsck of the file systems and runs of badblocks did not reveal any file
system or disk problems.

Apart from this, F8 appears to work fine on this notebook.

I will attach dmesg and lspci from both notebooks.
Comment 1 Bojan Smojver 2007-11-09 16:19:02 EST
Created attachment 253541 [details]
lspci -vv from the notebook that fails hibernation
Comment 2 Bojan Smojver 2007-11-09 16:19:40 EST
Created attachment 253551 [details]
dmesg from the notebook that fails hibernation
Comment 3 Bojan Smojver 2007-11-09 16:21:57 EST
Created attachment 253561 [details]
lspci -vv from the notebook that doesn't fail hibernation
Comment 4 Bojan Smojver 2007-11-09 16:22:25 EST
Created attachment 253571 [details]
dmesg from the notebook that doesn't fail hibernation
Comment 5 Bojan Smojver 2007-11-09 17:16:26 EST
In fact, downgrading to F7 kernel (2.6.23.1-21.fc7) makes this go away on F8 as
well.
Comment 6 Chuck Ebbert 2007-11-09 17:39:12 EST
(In reply to comment #0)
> Description of problem:
> 
> With upgrade to F8, one of my Dell Inspiron 6400 notebooks fails to hibernate
> with errors related to writes to disks (along the lines of: unable to write to
> swap, EXT3-fs unable to write etc.).

We need to see the exact messages.
Comment 7 Bojan Smojver 2007-11-09 18:28:23 EST
> We need to see the exact messages.

Yeah, I knew you were going to say that :-)

Had my camera ready, but then the failure decided to hang my X instead. I'll try
to reproduce again and take a photo.

BTW, there is nothing in the logs (i.e. the file system is already screwed at
that point). Any other way to catch this, apart from taking a photo?
Comment 8 Bojan Smojver 2007-11-09 19:30:29 EST
Created attachment 253721 [details]
Error as seen from run level 3 after running pm-hibernate
Comment 9 Bojan Smojver 2007-11-09 19:31:27 EST
Created attachment 253731 [details]
End of dmesg output (sorry, more/less would not work - I/O error)
Comment 10 SJM 2007-11-12 06:16:53 EST
Created attachment 255081 [details]
lspci-vv
Comment 11 SJM 2007-11-12 06:18:26 EST
I can confirm this with kernel 2.6.23.1-49.fc8
Dell 6400 notebook too. I think it happens on suspend too, because when it
resumes I see the cursor but nothing else.

Like OP many disk errors on resume. see attachment above
Comment 12 SJM 2007-11-12 06:31:17 EST
I can confirm that 2.6.23.1-21.fc7 (from FEDORA 7) works fine for suspend and
hibernate and I can resume fine.

I suspect that this bug applies both to hibernation and suspend. When suspending
with the f8 kernel, it suspends but appears to be a read only file system on
resume (only cursor moves, can't change console etc..). On hibernation lots of
disk errors - same as bug reporter.

I've installed the i686 version of the f7 kernel and no problems
Comment 13 Paul Stewart 2007-11-15 14:11:37 EST
Created attachment 260241 [details]
excerpt of lspci -vv and dmesg for ICH7 SATA controller
Comment 14 Paul Stewart 2007-11-15 14:12:52 EST
My Dell M1710 (lshal smbios.system.product = 'MXG061') also has this problem. 
Hibernate worked well in F7, but now crashes in an identical error (ext3 sends
scary messages about I/O errors).  Suspend to RAM appears to succeed (goes to
sleep), but again it resumes in a very angry state, losing all access to the
disk drive.  Dmesg has errors like:

end_request: I/O error, dev sda, sector 35517611
sd 0:0:0:0: [sda] Result: hostbyte=DID_BAD_TARGET driverbyte=DRIVER_OK,SUGGEST_OK

Other distros like Ubuntu appear to have run into this as well, and some claim
to have fixed it. 
https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.22/+bug/149249

I've attached segments of lspci -vv and dmesg that show the controller.  If you
want the whole thing let me know.
Comment 15 Bojan Smojver 2007-11-19 17:28:58 EST
I see 2.6.23.8-61.fc8 is being built in Koji. Is it likely to contain fixes for
this bug?
Comment 16 Bojan Smojver 2007-11-19 22:35:32 EST
This one (2.6.23.8-61.fc8) works on my box.
Comment 17 Paul Stewart 2007-11-20 17:11:16 EST
2.6.23.8-61.fc8 also fixes my hibernate problems, and the machine comes back
to life after a suspend as well (the NVidia-based display doesn't come out of
sleep, but that's a separate and known issue)
Comment 18 SJM 2007-11-21 04:37:02 EST
I can confirm 2.6.23.8-61.fc8 fixes this issue
Comment 19 Jackie 2007-12-09 16:17:05 EST
As of kernel 2.6.23.8-63.fc8, my hibernate function has broke. It appears to
hibernate correctly, but when I try to wake it up, all I get is the cursor
flashing in the top left of the screen. I have not tried suspend yet, but I am
guessing it will react the same. 
Comment 20 Christopher Brown 2008-02-03 19:09:09 EST
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.
Comment 21 Bojan Smojver 2008-02-03 23:08:40 EST
As reported before in this bug, this has been fixed.

Note You need to log in before you can comment on or make changes to this bug.