Bug 373861 - add fortran modules macro and FFLAGS switch
add fortran modules macro and FFLAGS switch
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: redhat-rpm-config (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Jon Masters
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: 257701 257761 427121
  Show dependency treegraph
 
Reported: 2007-11-09 16:43 EST by Patrice Dumas
Modified: 2009-03-02 08:56 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-02 08:56:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrice Dumas 2007-11-09 16:43:53 EST
Description of problem:

According to Tibbs, the proposal
http://fedoraproject.org/wiki/PackagingDrafts/FortranModulesDir
has been accepted.

So I ask to add in the macros file

%_fmoddir               %{_libdir}/gfortran/modules

and modify FFLAGS to read

  FFLAGS="${FFLAGS:-%optflags -I%_fmoddir}" ; export FFLAGS ; \

My test shows that the -I%_fmoddir should also be in 
redhat/macros

I leave to you what should be in upstream macros file and 
in redhat/macros

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Panu Matilainen 2007-11-10 07:28:07 EST
This is distro packaging policy really, belongs to redhat-rpm-config.
Comment 2 Patrice Dumas 2007-11-29 05:59:18 EST
Could this be worked on? Some multilib fixes would easily be fixed 
once this is done.

I can provide patches, though they are quite trivial.
Comment 3 Patrice Dumas 2008-01-27 06:41:04 EST
Last comment is 2 month old. This change is trivial, corresponds
with a packaging policy, blocks proper packaging of packages that 
are shipping mod files. Could this be acted upon?

I don't think it makes sense to start the MIA procedure, I guess
that people are still here.
Comment 4 Jon Masters 2008-04-25 21:53:26 EDT
This was filed under a different user account so I didn't see the bug. I have
taken steps to correct this and will look into this.
Comment 5 Patrice Dumas 2008-06-18 07:03:55 EDT
Could it be possible to push that change to F-9 too?
Comment 6 Bug Zapper 2008-11-25 21:02:48 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Patrice Dumas 2009-03-02 08:56:01 EST
Closing, since nobody seems to care, F9 is certainly too old to care about. Moreover Jakub disagrees on fmoddir.

Note You need to log in before you can comment on or make changes to this bug.