This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 373941 - gnuplot update breaks dependencies
gnuplot update breaks dependencies
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnuplot (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ivana Varekova
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-09 17:23 EST by Michal Jaegermann
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-16 08:37:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2007-11-09 17:23:32 EST
Description of problem:

After 'yum update gnuplot':
.....
Resolving Dependencies
--> Running transaction check
---> Package gnuplot.x86_64 0:4.2.2-4.fc9 set to be updated
--> Processing Dependency: gnuplot = 4.2.0-7.fc8 for package: gnuplot-emacs
--> Finished Dependency Resolution
Error: Missing Dependency: gnuplot = 4.2.0-7.fc8 is needed by package gnuplot-emacs

I doubt very much that gnuplot-emacs has to depend on a specific
version of gnuplot.  OTOH this is strange as gnuplot-emacs is
a subpackage of gnuplot.

Version-Release number of selected component (if applicable):
gnuplot-4.2.2-4.fc9

How reproducible:
always
Comment 1 Ivana Varekova 2007-11-12 12:18:13 EST
Thanks, fixed in gnuplot-4.2.2-5.fc9.
Comment 2 Michal Jaegermann 2007-11-13 13:00:44 EST
> fixed in gnuplot-4.2.2-5.fc9

I am afraid that this does not work and yum still throws a fit.

The problem is that there were packages gnuplot-4.2.0-7.fc8 and
gnuplot-emacs-4.2.0-7.fc8 and the later one has a very specific
requirement "gnuplot = 4.2.0-7.fc8".

Now for some reasons a name of the second package changed to
emacs-gnuplot-4.2.2-5.fc9 and even if this version provides
"gnuplot-emacs" tag then yum on an update comes back with:
"Package emacs-gnuplot not installed, cannot update it."
That when trying an update with specific package names.  It looks
that you need an "obsoletes" tag, instead of "provides", before
yum will consider a replacement.

I would fully expect that the same gotcha will show up with
gnuplot-emacs-el --> emacs-gnuplot-el transition.

Moreover the last name is doubly weird.  If all this mess was really
necessary then "emacs-el-gnuplot" would seem like something more
reasonable.
Comment 3 Ivana Varekova 2007-11-16 08:37:00 EST
Thanks, obsoletes tag added to both subpackages (and provides to -el). 
(gnuplot-4.2.2-6.fc9)
The name is right due to
http://fedoraproject.org/wiki/Packaging/Emacs#head-5ef57b56b44bd58c8fee3dd936b49b826ce4cd24
page.
Comment 4 Michal Jaegermann 2007-11-18 21:00:46 EST
Close but actually no cigar.  With new packages

$ rpm -q --obsoletes emacs-gnuplot-el
gnuplot-emacs

while this should be 'gnuplot-emacs-el' and that results in
emacs-gnuplot-el beeing installed even if no emacs .el files
for gnuplot support were present before and only .elc's.
Not the end of the world, but ....

Should I reopen this bug again?
Comment 5 Stepan Kasal 2007-11-23 07:50:04 EST
(In reply to comment #4)
> $ rpm -q --obsoletes emacs-gnuplot-el
> gnuplot-emacs
> 
> while this should be 'gnuplot-emacs-el' and that results in

No, package gnuplot-emacs-el has never existed.
gnuplot-emacs contained both *.el and *.elc files.

Note You need to log in before you can comment on or make changes to this bug.