Bug 374091 - gdm 2.21 falls apart after totally ignoring its configuration
gdm 2.21 falls apart after totally ignoring its configuration
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Target
  Show dependency treegraph
 
Reported: 2007-11-09 18:28 EST by Michal Jaegermann
Modified: 2008-03-09 15:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-07 18:20:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2007-11-09 18:28:34 EST
Description of problem:

Update gdm sports a configuration directory /usr/share/gdm/
but if one looks there this cannot be right as various things
described in comments there simply do not exist.  Indeed, new
gdm appears to totally ignore /etc/gdm/custom.conf and, in
particular, such essential settings there like
Greeter, AllowRoot, Browser, MinimalUID, Logo, BackgroundProgram,
etc... making the whole thing basically unusable (at least for
me).  Documentation does not exist either in that rpm package
or on http://www.gnome.org/projects/gdm/ site and no means of
affecting a configuration seems to be present.  A bit rushed?

Version-Release number of selected component (if applicable):
gdm-2.21.1-0.2007.10.30.1.fc9
Comment 1 Ray Strode [halfline] 2007-11-09 23:22:08 EST
Hi,

So GDM is going over a lot of big changes right now.  See:

https://www.redhat.com/archives/fedora-devel-list/2007-October/msg01766.html

A lot of things aren't hooked up yet.  Also, the configuration file format has
changed.  Things should look a lot different as we get further in the F-9 devel
cycle.
Comment 2 jmccann 2008-03-07 18:20:22 EST
We have a few of the configuration options hooked up now.  However, there are a
good number of them that we are no longer supporting.  If you any specific
problems please report them upstream.  Thanks.
Comment 3 Michal Jaegermann 2008-03-09 15:37:34 EDT
> We have a few of the configuration options hooked up now.

Maybe.  There is no way to tell as a documentation either in
a rawhide package or on http://www.gnome.org/projects/gdm/
for version 2.21 does not exist.  I do not see also any kind
of a configuration "helper" and an old /etc/gdm/custom.conf
is plainly ignored.  There is also no new sample configuration
file which would show possible valid settings.

My minimal requirements are at least two servers running
on different consoles and a custom background instead of
a default one (and if setting different backgrounds for different
servers can be done without strange hacks that is definite plus).
Other configuration options could be really useful.

In the current form gdm-2.21 is plain useless for me so I am
going to ignore it.

Note You need to log in before you can comment on or make changes to this bug.