Bug 374171 - spaces in URL crash pirut
Summary: spaces in URL crash pirut
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut   
(Show other bugs)
Version: 8
Hardware: i686
OS: Linux
low
low
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: EasyFix
Depends On:
Blocks: F9Blocker
TreeView+ depends on / blocked
 
Reported: 2007-11-10 00:52 UTC by Allen
Modified: 2007-12-31 14:51 UTC (History)
1 user (show)

Fixed In Version: 1.3.28
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-31 14:51:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Allen 2007-11-10 00:52:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9

Description of problem:
A URL of the form file://<pathname with a space> will cause pirut to crash.

Tried entering from the GUI when trying to add the dvd as a repo which was auto-mounted under /media/Fedora 8 DVD. So I tried to alter /etc/yum.repos.d/fedora.d (yes, I messed with a known good repo entry). Same result.

It seems pirut expects all URLs to already be url-encoded. Had to remount dvd with a non-space containing pathname.

Version-Release number of selected component (if applicable):
pirut-1.3.25-2.fc8

How reproducible:
Always


Steps to Reproduce:
1. pick a <name>.repo file in /etc/yum.repos.d
2. add a space to the url of any baseurl definition
3. run pirut

Actual Results:
pirut shows a uninformative stack trace claiming that the url was "" and dies ...

Expected Results:
pirut understands urls with spaces 

Additional info:

Comment 1 Allen 2007-11-12 05:47:31 UTC
The error is in yum, not pirut.

The code causing this is /usr/lib/python2.5/site-packages/yum/config.py line
142. It is explicitly stated there that spaces are delimiters.

So I suppose this is not a bug. Just not compliant with RFC 2396 or with all
possible filenames. 

Perhaps some change to man yum.conf?

Comment 2 Jeremy Katz 2007-11-12 16:01:02 UTC
Actually, we should do appropriate munging from, eg, space to %20 in pirut when
doing the config editing.

Will fix for an F8 update

Comment 3 Jeremy Katz 2007-11-19 19:18:33 UTC
Fixed in git; will be pushed as an update shortly

Comment 4 Fedora Update System 2007-11-20 17:50:03 UTC
pirut-1.3.26-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pirut'

Comment 5 Fedora Update System 2007-11-29 01:34:02 UTC
pirut-1.3.27-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pirut'

Comment 6 Fedora Update System 2007-12-06 20:45:29 UTC
pirut-1.3.28-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2007-12-06 20:55:07 UTC
pirut-1.3.28-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Jeremy Katz 2007-12-31 14:51:55 UTC
New versions of pirut have been released that should address these issues


Note You need to log in before you can comment on or make changes to this bug.