Bug 374191 - F8's crond uses incorrect sendmail path
F8's crond uses incorrect sendmail path
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: vixie-cron (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-09 20:05 EST by Jordan Russell
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 4.2-5.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-12 19:11:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jordan Russell 2007-11-09 20:05:50 EST
Description of problem:
Fedora 8's crond expects to find sendmail in /usr/lib:

# strings /usr/sbin/crond | fgrep sendmail
/usr/lib/sendmail

This is incorrect; the standard location for sendmail on Red Hat Linux systems
is /usr/sbin/sendmail, and has been for probably a decade.
If the above test is repeated on a system running Fedora 7 or RHEL 5,
"/usr/sbin/sendmail" is printed, as expected.

Out of the box, this doesn't create a problem since Fedora 8's default sendmail
package drops a sendmail symlink into /usr/lib. But if, like me, you use a
custom-built MTA package that doesn't provide /usr/lib/sendmail, crond will
mysteriously cease sending mail after upgrading to Fedora 8. Not good.

This issue is specific to the vixie-cron package; all other F8 packages I've
checked thus far continue to use the proper /usr/sbin/sendmail path.

Version-Release number of selected component (if applicable):
vixie-cron-4.2-3.fc8
Comment 1 Fedora Update System 2007-11-12 19:11:21 EST
vixie-cron-4.2-5.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.