Bug 374291 - pcscd using 100% cpu 100% of the time
pcscd using 100% cpu 100% of the time
Status: CLOSED DUPLICATE of bug 350441
Product: Fedora
Classification: Fedora
Component: pcsc-lite (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Bob Relyea
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-09 23:31 EST by Tom Horsley
Modified: 2008-04-20 21:29 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-20 21:29:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
picture of top in putty showing cpu usage (43.63 KB, image/gif)
2007-11-16 08:27 EST, D'Lane Reiswig
no flags Details

  None (edit)
Description Tom Horsley 2007-11-09 23:31:56 EST
Description of problem:

In a fresh install of fedora 8 on dual core x86_64 box, after logging in
for first time after install, I notice system monitor says the cpu is
pegged at 50% (100% on one core). I run top and find that pcscd is pegged
at 100%.

Version-Release number of selected component (if applicable):
pcsc-lite - 1.3.3-1.fc8.x86_64

How reproducible:
seems totally reproducible on this system

Steps to Reproduce:
1. install fedora 8
2. login as root
3. run top and see pcscd eating as much time as it can get
  
Actual results:

See above.

Expected results:

Since I have no smart card hardware, I wouldn't expect it to use much time.
(In fact, it is one of the services I normally disable once I get to
configuring the system).

Additional info:
Comment 1 Joachim Selke 2007-11-12 05:14:07 EST
I have exactly the same problem with my notebook running Fedora 8 (i386).
Comment 2 Bernd Bartmann 2007-11-12 10:30:06 EST
Same here on a DELL D620. After some uptime I see pcscd eating all the CPU time
(not very helpful for the battery voltage level :-( )
Comment 3 Tom Horsley 2007-11-12 18:27:25 EST
Just installed F8 on a system at work today (i386 this time, not x86_64) and saw
the same thing as soon as the install was done.
Comment 4 David Keaton 2007-11-13 13:55:01 EST
I see the same thing on a fresh F8 32-bit install as a VMware Workstation 6 guest.
Comment 5 D'Lane Reiswig 2007-11-16 08:27:12 EST
Created attachment 261221 [details]
picture of top in putty showing cpu usage
Comment 6 D'Lane Reiswig 2007-11-16 08:36:50 EST
log entries in /var/log/messages that look to be related:

Nov 15 18:52:26 localhost pcscd:
hotplug_libusb.c:394:HPEstablishUSBNotifications() Driver ifd-cyberjack.bundle
does not support IFD_GENERATE_HOTPLUG
Nov 15 18:52:34 localhost pcscd: winscard.c:219:SCardConnect() Reader E-Gate 0 0
Not Found
Nov 15 18:52:34 localhost pcscd:last message repeated 3 times

Comment 7 Matthew Sale 2007-11-22 19:37:01 EST
Same problem, except with fedora 7 32-bit AMD-64, pcscd eating all the cpu it
can get, with or without my smartcard reader.

rpm -q libusb pcsc-lite ccid
libusb-0.1.12-7.fc7
pcsc-lite-1.3.3-1.fc7
ccid-1.2.1-1.fc7


Nov 22 17:00:02 mattsk7 syslogd 1.4.2: restart.
Nov 22 18:00:02 mattsk7 syslogd 1.4.2: restart.
Nov 22 18:50:02 mattsk7 pcscd: winscard.c:271:SCardConnect() Card Not Inserted
Nov 22 18:50:37 mattsk7 last message repeated 7 times
Nov 22 18:51:09 mattsk7 last message repeated 4 times
Nov 22 18:52:07 mattsk7 pcscd: eventhandler.c:419:EHStatusHandlerThread() Card
inserted into Generic CCID Reader (21120744211967) 00 00
Nov 22 18:52:07 mattsk7 pcscd: Card ATR: 3B 7F 11 00 00 00 31 C0 53 CA C4 01 64
52 D9 04 00 82 90 00 
Nov 22 18:52:07 mattsk7 pcscd: prothandler.c:130:PHSetProtocol() Attempting PTS
to T=0
(In reply to comment #6)
> log entries in /var/log/messages that look to be related:
> 
> Nov 15 18:52:26 localhost pcscd:
> hotplug_libusb.c:394:HPEstablishUSBNotifications() Driver ifd-cyberjack.bundle
> does not support IFD_GENERATE_HOTPLUG
> Nov 15 18:52:34 localhost pcscd: winscard.c:219:SCardConnect() Reader E-Gate 0 0
> Not Found
> Nov 15 18:52:34 localhost pcscd:last message repeated 3 times
> 
> 

Comment 8 Matthew Sale 2007-11-23 09:46:51 EST
pcsc-lite-1.4.4 seems to cure this problem on fedora 7.
Comment 9 Bob Relyea 2007-11-28 13:30:30 EST
Thanks, I've checked pcsc-lite-1.4.4 with old drivers (FC6) with no problems.
I'll upgrade rawhide shortly.

Question: is there a desire for F8 and F7 updates of this package as well?


bob

BTW We should still update any ifd that does not support IFD_GENERATE_HOTPLUG in
the fedora tree.
Comment 10 Matthew Sale 2007-11-28 20:34:53 EST
I would vote yes.

Thanks,

Matt
Comment 11 Jeff Krebs 2008-01-02 12:20:49 EST
I was having the same issue with pcscd using a high CPU percentage.

Rebuilding and installing the pcsc-lite 1.4.4 .src.rpm from rawhide fixed the issue.

Please push the newest version out to FC7/F8.
Comment 12 Todd Denniston 2008-01-07 13:09:45 EST
Question to those for whom Rebuilding and installing the pcsc-lite 1.4.4 is
fixing the problem:
if you run `rpm -qa |grep ifd` do you see more than ifd-egate?
I am wondering if you removed all the ifd's and only put back those that came
with the new pcsc.?.?

for us, just issuing `rpm -e ifd-cyberjack` (and restarting pcscd) fixed the
problem.

you only need the ifd- bundle for the card reader you have, and for most that is
the ccid bundle, which for some reason comes in the ccid rpm instead of ifd-ccid.
Comment 13 Jeff Krebs 2008-01-09 02:10:09 EST
I rebuilt the development pcsc-lite 1.4.4 .src.rpm and installed it with "rpm
-Uvh pcsc-lite*.i386.rpm".

Executing you "rpm -qa |grep ifd" gives only one ifd-egate:

ifd-egate-0.05-19

I'm running an Athena ASEDrive IIIe Reader USB; I had no luck with the stock
ccid 1.2.1 rpm.  I actually built my own Athena driver rpm and installed that. 
Things worked fine after that.  The Athena reader is supposed to be CCID
compliant.  Perhaps I needed to tweak the scripts a bit.  Don't know.

I can gladly post the Athena spec file I built if you need that for anything.  
Comment 14 Dan Bratten 2008-03-19 05:19:42 EDT
Same problem with pcscd here too:

Having installed F8 32Bit on 5 different systems, pcscd had problems on three of
them.
Comment 15 Zachary Napora 2008-04-20 21:29:23 EDT

*** This bug has been marked as a duplicate of 350441 ***

Note You need to log in before you can comment on or make changes to this bug.