Bug 37435 - Additional output for 'rpm -F --test'
Summary: Additional output for 'rpm -F --test'
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-24 15:22 UTC by Valdis Kletnieks
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-24 15:22:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Valdis Kletnieks 2001-04-24 15:22:26 UTC
Let's say you have a directory with a large number of RPMs in it (for 
instance, the 'rawhide' or 7.1 distribution).  If you say:

rpm -Fv --test *.rpm

it will walk through and check for conflicts, but will *NOT* say which
RPM's would acttallly be installed.

Possible desired output:

# rpm -Fv --test *.rpm
Would install 'Abra-4.0.3-12'
Woud install 'Cadabra-2.14'
Would NOT install 'Dungball-0.0.3'
Would install 'Frobozz-0.19'

Motivation:  Allow the sysadmin to see what would really be done.

The documentation at
http://www.redhat.com/support/manuals/RHL-7.1-Manual/customization-guide/s1-rpm-using.html

under 'Freshen' specifically recommends using '*.rpm', but glosses over the
fact that if you downloaded using 'wget' to mirror, or an FTP 'mget *.rpm',
there *may* be packages in there that you do *not* want to install (perhaps
you have 3-rd party software or other considerations that keep you from
upgrading a given RPM).

If you've ever known anybody who used 'rpm -Fv *.rpm' and got screwed
because the glob picked up something they didn't want upgraded just yet,
then you know what I mean... ;)

Comment 1 Jeff Johnson 2001-04-24 17:33:48 UTC
FWIW, the packages chosen by --freshen are displayed with -vv,
look for the list after the "========= tsorting packages" message.

Adding new messages to -v is not desireable because:
	rpm is designed for unattended "batch mode"
	operation. This design goal is directly in conflict
	with you (perfectly understandable :-) request
	for better info.
Basically, I can't easily change the output behavior of the option -v
because there are far too many programs/scripts that depend on
the existing behavior. The option -vv is a different story ...


Note You need to log in before you can comment on or make changes to this bug.