Bug 374381 - kernel crash during fedora 8 upgrade on hp nx6125
Summary: kernel crash during fedora 8 upgrade on hp nx6125
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 8
Hardware: All Linux
low
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-10 07:42 UTC by Levente Farkas
Modified: 2008-06-18 22:36 UTC (History)
1 user (show)

Fixed In Version: 2.6.25
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-18 22:36:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Levente Farkas 2007-11-10 07:42:04 UTC
Description of problem:
hi,
after some google search i found out how to get through the dependencies
resolution after 26% (remove dbus, expat and avahi) i able to ugrade 3
of my workstations to f8. the problem comes when i try to upgrade my hp
nx6125 laptop which has exactly the same packages installed as my
workstations and works with fedora 7 (i386 and still would like to use
i386). after another few google i found these:
http://www.centos.org/modules/newbb/viewtopic.php?topic_id=3277
http://www.clasohm.com/blog/one-entry?entry_id=14560
http://ubuntuforums.org/showthread.php?t=119426
i exactly has the same syndrome with f8 upgrade from dvd ie. it'e
terrible slow (10-100 times!!!). if i gives the noapic nolapic kernel
option for the installer it's use the normal speed, but kernel crash
when start /sbin/loader.
so my question is there any solution for this?
is it a kernel bug or is there any solution to be able to upgrade to f8
and use it in an acceptable speed?
anyways if i do live yum upgrade (ie. not boot from dvd) the the new kernel will
run with the same speed after reboot? since in this case i rather wait for an
updated kernel. or it's not a kernel related problem?
thanks in advance.

Version-Release number of selected component (if applicable):
kernel-2.6.23.1-42.fc8
while the previous version with f7 kernel-2.6.23.1-21.fc7 has no such problem.

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Levente Farkas 2007-11-10 19:54:56 UTC
and here is the solution:
http://ubuntuforums.org/showthread.php?t=53094&highlight=nx6125
The only way to find out without installing Ubuntu 32bit is to use an Ubuntu
(32-bit) LIVECD and to try to prompt one (and ONLY 1 PER TIME) of the following
options at boot:
1) noapic nolapic
OR
2) noapic acpi=noirq
OR
3) noapic acpi=off
OR
4) noapictimer
OR
5) noapictimer irqpoll

Comment 2 Christopher Brown 2008-02-04 00:21:05 UTC
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Live Yum upgrades are
not recommended as per:

http://fedoraproject.org/wiki/YumUpgradeFaq

and if you are having issues then I would recommend using the DVD to upgrade.

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.

Comment 3 Levente Farkas 2008-02-15 21:14:23 UTC
the problem still exists, the only solution what i find is:
noapic nolapic 
kernel option. and in this case i can boot, but i don't think this can be a
final solution.

Comment 4 Levente Farkas 2008-06-18 18:22:24 UTC
please close this bug since it's been already solved in f9


Note You need to log in before you can comment on or make changes to this bug.