Bug 37439 - mount reports failed mount but succeeds
Summary: mount reports failed mount but succeeds
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mount   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-24 15:47 UTC by Derek Price
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-17 19:27:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Derek Price 2001-04-24 15:47:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686)


Every reboot, my mount reports:

Apr 24 10:44:18 empress mount: mount: mount point /var/lib/amanda/staging
does n
ot exist

but the mountpoint exists and when I open a shell the disk has been
mounted.

Reproducible: Always
Steps to Reproduce:
1.  sudo mkdir -p /var/lib/amanda/staging
2.  set up fstab to mount a partition onto /var/lib/amanda/staging
3.  reboot (mount -a doesn't show the same symptoms)
	

Actual Results:  Produced (approximately) the following error message:

mount: mount point /var/lib/amanda/staging does not exist
				[FAILED]


Expected Results:  rc script should have reported [PASSED] for this
section.

Maybe fixed string length somewhere makes existence test fail but not
mount?

Comment 1 Bernhard Rosenkraenzer 2002-01-17 19:27:15 UTC
By any chance, is /var a separate partition? In that case, is it possible you're
trying to mount /var/lib/amanda/staging before /var is mounted?

Comment 2 Bernhard Rosenkraenzer 2002-02-02 11:27:56 UTC
Closing due to lack of feedback

Comment 3 Derek Price 2002-04-05 16:49:53 UTC
Sorry about the delayed reply.

Looks like you were right.  I think I changed the order of mounts in /etc/fstab
so that /var/lib/staging/amanda is listed after /var and I stopped seeing the
error message.  I wasn't keping a revision history of the fstab file at the
time, so I'm not sure and I may have set the fscheck order flag to 2, but I
think it was just the line order I switched.  Not sure why it printed the error
message _and_ mounted before, but I no longer see the errant message.

Thanks for your help.


Note You need to log in before you can comment on or make changes to this bug.