Bug 37440 - Proxy option doesn't work without DNS
Proxy option doesn't work without DNS
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: rhn_register (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-24 11:47 EDT by Need Real Name
Modified: 2015-01-07 18:45 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-05 22:10:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-04-24 11:47:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)


The proxy server option for rhn_register doesn't work when using just the 
IP address for the for the proxy.  Not running DNS on our LAN.  Tried 
using hostname in /etc/hosts.  Still get error "Fatal error retreiving 
welcome message: No route to host."  Same error on RH 7.1.

Reproducible: Always
Steps to Reproduce:
1.Use "rhn_register --configure" to set "enableProxy = Yes" and "httpProxy 
=  192.168.1.150:3128" (running squid as proxy).
2.Run rhn_register
3.Get error.
	

Using rhn_register version 1.3.2-0.6.x and rhn_register-gnome-1.3.2-
0.6.x.
Comment 1 Adrian Likins 2001-07-05 22:10:20 EDT
There was an error in the config comments about the format
of the the proxy host string. Basically, it said to enter
the format as "192.68.0.1:3000", but unfortunately, the
clients always expected it in the form of "http://192.168.0.1:3000",
so it's possible that it wasnt parsing the ip address correctly,
and was looking for a non-existent host.

The next version will rectify this (correct the comment, and a code
change to accept both formats).

The client should be able to use an ip address as the proxy host
without any problems, if the config option is in the right format.
Comment 2 Jay Turner 2001-07-05 22:41:48 EDT
Indeed this is fixed in CVS.  rhn_register config now understands both IPs and
hostnames and they can be specified as 'hostname.machine.com:<port>' or
'http://hostname.machine.com:<port>'

Note You need to log in before you can comment on or make changes to this bug.