Bug 37441 - Errors on deleting non-empty directories on upgrade aren't useful
Summary: Errors on deleting non-empty directories on upgrade aren't useful
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-24 15:51 UTC by Ed McKenzie
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-24 17:26:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ed McKenzie 2001-04-24 15:51:07 UTC
rpm tries to delete directories once it has reason to think that directory 
no longer contains files, but in practice it ends up printing lots 
of "error: cannot remove /... - directory not empty."  I don't think this 
event is significant enough to print an error message, but that's just MHO.

In any case, it does seem odd to me that it prints this while performing a 
package upgrade.

Comment 1 Jeff Johnson 2001-04-24 17:26:49 UTC
Yup. Reporting failed rmdir's is important to installer's and packagers,
but needlessly confuses users.

The error message will not be displayed if/when rpm runs a proper
package reference count on directories. The first step, adding an
index on directories in order to calculate the reference count is
in rpm-4.0.3. The final step, retrieving the number of packages
that use a directory so that the error messages will be displayed
only when the last package attempts a rmdir that fails remains.

Comment 2 Jeff Johnson 2001-05-06 14:10:00 UTC
I'm marking this as CURRENTRELEASE, because the (bogus IMHO) error message is
what is desired in rpm at the moment.


Note You need to log in before you can comment on or make changes to this bug.