Bug 374411 - Unusual kernel messages during boot
Unusual kernel messages during boot
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-10 04:24 EST by Mike Cohler
Modified: 2009-11-02 05:14 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.6.23.1-49.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-12 16:10:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages (73.13 KB, text/plain)
2007-11-10 04:25 EST, Mike Cohler
no flags Details

  None (edit)
Description Mike Cohler 2007-11-10 04:24:59 EST
Description of problem:Unusual kernel messages during boot for Dell D610 running
clean F8


Version-Release number of selected component (if applicable):
2.6.23.1-42.fc8


How reproducible:Every time


Steps to Reproduce:
1. Boot machine
2.
3.
  
Actual results:Kernel messages on screen:
Nov  9 17:37:27 localhost kernel: Uhhuh. NMI received for unknown reason a1
on CPU 0.
Nov  9 17:37:27 localhost kernel: You have some hardware problem, likely on
the PCI bus.
Nov  9 17:37:27 localhost kernel: Dazed and confused, but trying to continue


Expected results:Boot should not have these messages


Additional info:Machine is an unmodified Dell D610 laptop. Hardware profile is
at http://smolt.fedoraproject.org/show?UUID=3d9d22e7-ba03-43a0-bd49-078425bae8f5

This machine was running F7 until yesterday without any issues at all. There
were issues during install being unable to boot the installer - fix was
described as in http://smolts.org/wiki/System/Dell_Inc./Latitude_D620 and this
allowed the install to continue. I don't know if this is related to the bug
being reported here?

/var/log/messages file will be attached shortly.
Comment 1 Mike Cohler 2007-11-10 04:25:50 EST
Created attachment 253851 [details]
/var/log/messages
Comment 2 Mike Cohler 2007-11-10 05:27:51 EST
This morning I have updated to the new kernel 2.6.23.1-49.fc8. These boot
messages no longer appear!  

I will leave this bug open and do further tests this evening. If the boot
messages do not get seen again then I will close this bug.
Comment 3 Mike Cohler 2007-11-10 06:25:44 EST
I also notice that during shutdown there is a message:
Stopping irqbalance - failed

Is this related to the above kernel issues?
Comment 4 Mike Cohler 2007-11-10 17:09:31 EST
I realised my comment #3 is a dumb one!  This machine has only one core - but
this failed message when stopping irqalance was reported previously in
development versions (bz 355231) before f8 was released. Therefore ignore #3
Comment 5 Jóhann B. Guðmundsson 2007-11-12 04:25:36 EST
Same message kernel being dazed and confused in pops
up now and then in Dell Inspiron 6000

Have received this through FC6, FC7 and now FC8 but no
error so far with kernel 2.6.23.1-49.fc8

Started to receive this in FC6 after I did some hack to get
smoother dvd playback,I cant remember the exact steps i did
nor can I guarantee that this is not an actually HW failure
since I got flammable battery with the laptop.
 
I was fast enough to remove the battery before the computer 
turned on fire, but not fast enough for my hard drive so other 
things than the hard drive might have gotten damaged.
 
Did not need to do the hack in FC7 since dvd playback was smooth..
But the kernel still reported now and then being dazed..

I have always made message == HW failing due to damage done by flammable battery

But this could be related to kernel + motherboard + DVD/CD drive in Dell Laptops
since the first time I received it was after I did some hack to get smoother dvd
playback..

Hope this helps....
Comment 6 Mike Cohler 2007-11-13 04:12:08 EST
Thanks for closing this bug - for me it is indeed resolved with the newer kernel
Comment 7 mether 2008-02-09 12:56:04 EST
I am getting the same messages on Dell Latitude 810.

Feb  9 23:04:45 kernel: Uhhuh. NMI received for unknown reason b0 on C
PU 0.
Feb  9 23:04:45 kernel: You have some hardware problem, likely on the 
PCI bus.
Feb  9 23:04:45 kernel: Dazed and confused, but trying to continue

My laptop hang and needs to be hard rebooted. I am using 2.6.23.9-85.fc8 #1 SMP
Fri Dec 7 15:49:59 EST 2007 i686 i686 i386 GNU/Linux
Comment 8 Mike C 2008-02-09 13:24:45 EST
I have not had any further problems with F8 - am currently running
2.6.23.14-115.fc8. The previous kernel was fine also.
Comment 9 Jóhann B. Guðmundsson 2008-02-09 13:42:40 EST
Confirmed again on Dell Inspiron 6000

Simple grep through /var/log/messages shows it's still present...

Feb  8 04:55:55 localhost kernel: Uhhuh. NMI received for unknown reason b0 on
CPU 0.
Feb  8 04:55:55 localhost kernel: You have some hardware problem, likely on the
PCI bus.
Feb  8 04:55:55 localhost kernel: Dazed and confused, but trying to continue

Kernel 2.6.23.14-115.fc8

One thing we all have in common ( Me Mike and Mether ) we all have Dell Laptops!

It would be good to get some info on how to debug this further to be able to
nail down the cause of this. 

I gladly would like to know if my hardware actually is failing or if this is an
kernel bug! 
Comment 10 mether 2008-02-10 00:21:49 EST
Johannbg to isolate this I installed windows XP ( I know its a bad idea ) and it
seems there is no issue if I use it for hours. System works fine. So looks like
something related to Linux only.
Comment 11 pandi 2009-11-02 05:14:46 EST
We are using Fedora Core 7 with 2.6.21 kernel and facing a issue in booting.

We have our PCI device on PCI slot and getting below message when system is booting

Uhhuh. NMI received for unknown reason a1 on CPU 0.

You have some hardware problem, likely on the PCI bus.
Dazed and confused, but trying to continue

what could be reason for above display ?

Note You need to log in before you can comment on or make changes to this bug.