Bug 374431 - selinux prevents terminal output from lvm commands when using rlogin
Summary: selinux prevents terminal output from lvm commands when using rlogin
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy
Version: 5.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
: 368041 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-10 09:39 UTC by Olle Liljenzin
Modified: 2008-05-21 16:06 UTC (History)
0 users

Fixed In Version: RHBA-2008-0465
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-05-21 16:06:04 UTC


Attachments (Terms of Use)
selinux messages (5.45 KB, text/plain)
2007-11-10 09:39 UTC, Olle Liljenzin
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0465 normal SHIPPED_LIVE selinux-policy bug fix update 2008-05-20 14:36:31 UTC

Description Olle Liljenzin 2007-11-10 09:39:21 UTC
Description of problem:
No output is printed to the terminal from lvm commands (lvdisplay, vgdisplay etc.)

Version-Release number of selected component (if applicable):
selinux-policy-2.4.6-30.el5

How reproducible:
always

Steps to Reproduce:
1. enable rlogin
2. run 'rlogin localhost'
3. run '/usr/sbin/lvm help'
  
Actual results:
no output

Expected results:
help text should be displayed

Comment 1 Olle Liljenzin 2007-11-10 09:39:21 UTC
Created attachment 253861 [details]
selinux messages

Comment 2 Daniel Walsh 2007-11-10 12:17:53 UTC
You can probably get around this by executing 

/usr/sbin/lvm help | cat


Comment 3 Olle Liljenzin 2007-11-10 13:11:31 UTC
Yes, I get the output if I pipe stderr.

But 'lvm help' was just a simplified example. Some commands are interactive,
e.g. lvremove, and I also suspect stdin being detached by selinux.

Comment 4 Daniel Walsh 2007-11-13 20:37:57 UTC
Please update to the U1 policy.  Preview is currently available on 

http://people.redhat.com/dwalsh/RHEL5


Comment 5 Olle Liljenzin 2007-11-14 08:29:55 UTC
The link above is broken...

Comment 6 Daniel Walsh 2007-11-14 15:11:27 UTC
http://people.redhat.com/dwalsh/SELinux/RHEL5

Sorry

Comment 7 Olle Liljenzin 2007-11-15 10:32:28 UTC
The packages are the same as we get from rhn?

Unfortunately they don't fix this bug.


Comment 8 Milan Broz 2008-01-04 12:00:01 UTC
*** Bug 368041 has been marked as a duplicate of this bug. ***

Comment 14 errata-xmlrpc 2008-05-21 16:06:04 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0465.html



Note You need to log in before you can comment on or make changes to this bug.