Bug 374471 - "ThinkPad Extra Buttons" device discarded by HAL
"ThinkPad Extra Buttons" device discarded by HAL
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-10 05:54 EST by Peter Williams
Modified: 2013-03-05 22:53 EST (History)
2 users (show)

See Also:
Fixed In Version: 9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-30 12:46:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Williams 2007-11-10 05:54:36 EST
Description of problem:

Certain keycode mappings are supposed to set up by HAL through the "ThinkPad
Extra Buttons" input device. See
fdi/information/10freedesktop/30-keymap-module-thinkpad-acpi.fdi. On my
computer, a T61, the Extra Buttons device is registered by the thinkpad_acpi
kernel module, but for some reason HAL discards the device. 

Version-Release number of selected component (if applicable):

hal-0.5.10-1.fc8
hal-info-20071030-1.fc8
hal-libs-0.5.10-1.fc8

Additional Information:

HAL is definitely detecting the input device corresponding to the Extra Buttons,
but he input probe on it is failing for some reason. The relevant verbose output
of HAL is:

02:22:59.241 [I] hotplug.c:142: /sys/class/input/input10/event9 is a device
(subsystem)
02:22:59.242 [I] device.c:3823: add_dev: subsys=input
sysfs_path=/sys/class/input/input10/event9 dev=/dev/input
02:22:59.242 [I] osspec.c:429: Synthesizing powermgmt events...
02:22:59.242 [I] acpi.c:729: Processing /proc/acpi/battery/BAT0
02:22:59.242 [I] acpi.c:729: Processing /proc/acpi/processor/CPU1
02:22:59.242 [I] acpi.c:729: Processing /proc/acpi/processor/CPU0
02:22:59.243 [I] acpi.c:729: Processing /proc/acpi/ac_adapter/AC
02:22:59.243 [I] acpi.c:729: Processing /proc/acpi/button/lid/LID
02:22:59.243 [I] acpi.c:729: Processing /proc/acpi/button/power/PWRF
02:22:59.243 [I] acpi.c:729: Processing /proc/acpi/button/sleep/SLPB
02:22:59.243 [I] acpi.c:729: Processing /proc/acpi/ibm/brightness
02:22:59.243 [I] acpi.c:837: Processing sonypi display
02:22:59.243 [I] osspec.c:431: ACPI capabilities found
02:22:59.243 [I] osspec.c:439: Done synthesizing events
02:22:59.244 [I] util.c:1049: Add callouts for
udi=/org/freedesktop/Hal/devices/computer
02:22:59.244 [I] hald_dbus.c:5186: ************************
02:22:59.244 [I] hald_dbus.c:5187: Client to local_server was disconnected for
9b61350
02:22:59.244 [I] hald_dbus.c:5188: ************************
02:22:59.244 [I] hald_dbus.c:5229: ***************************
02:22:59.244 [I] hald_dbus.c:5230: ********* unregistered 9b61350
02:22:59.244 [I] hald_dbus.c:5231: ***************************
02:22:59.244 [I] hald_dbus.c:5243: ***************************
02:22:59.244 [I] hald_dbus.c:5244: ********* got a connection 9b61350
02:22:59.244 [I] hald_dbus.c:5245: ***************************
02:22:59.244 [I] device.c:3740: entering; exit_type=0, return_code=1
02:22:59.244 [I] device.c:3751: device removed due to prober fail
device udi = /org/freedesktop/Hal/devices/temp/76
  button.state.value = false  (bool)
  linux.device_file = '/dev/input/event9'  (string)
  button.has_state = true  (bool)
  input.product = 'ThinkPad Extra Buttons'  (string)
02:22:59.244 [W] device.c:1374: Unknown property type 29548
  linux.subsystem = 'input'  (string)
  info.product = 'ThinkPad Extra Buttons'  (string)
  linux.hotplug_type = 2  0x2  (int)
  linux.sysfs_path = '/sys/class/input/input10/event9'  (string)
  info.category = 'input'  (string)
  input.device = '/dev/input/event9'  (string)
  info.parent = '/org/freedesktop/Hal/devices/computer'  (string)

I can't figure out a way to determine why the prober is failing for this device.
Comment 1 Tobias Kunze Briseño 2008-02-04 11:55:33 EST
This appears to be https://bugs.freedesktop.org/show_bug.cgi?id=13803
Comment 2 Richard Hughes 2008-05-30 07:37:36 EDT
Should be fixed in F9, now the thinkpad-laptop driver had been un-fubar'd.
Please confirm.
Comment 3 Peter Williams 2008-05-30 12:46:13 EDT
I see the "Thinkpad Extra Buttons" in the output of lshal now, so I think this
is fixed. To be honest I forget exactly what problem this bug was causing for
me, or whether I found a workaround for whatever that problem was, but it's
probably fine.

Note You need to log in before you can comment on or make changes to this bug.