Bug 37455 - Mail purge even when delivery fails
Mail purge even when delivery fails
Status: CLOSED DUPLICATE of bug 36640
Product: Red Hat Linux
Classification: Retired
Component: fetchmail (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Miloslav Trmač
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-04-24 13:29 EDT by Bertil Askelid
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-06-03 18:33:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Bertil Askelid 2001-04-24 13:29:40 EDT
fetchmail failed to deliver emails to my localhost mail box, and still it
went back and told the IMAP mail server to purge the email. I lost a days
worth of emails this way until I figurred out what was going on.

The reason for the failure was that sendmail obviously runs under a tcp
wrapper. My hosts.deny says ALL: ALL (yes, I AM paranoid). I had to put a
"sendmail:" in my /etc/hosts.allow. In a way it was good when
inetd.conf listed the services that was tcp wrapped. Where can I find a
list of commands that are tcp wrapped?
Comment 1 Miloslav Trmač 2005-06-03 18:33:54 EDT
I'm sorry about the late response.

This is a result of your configuration: sendmail is rejecting the messages
with a "permanent" error, so fetchmail decides not to keep the messages
in the mailbox.

Please see bug 36640 comment 5 for the detailed explanation

*** This bug has been marked as a duplicate of 36640 ***

Note You need to log in before you can comment on or make changes to this bug.