Bug 37456 - install hangs when loading 8139too.o module
Summary: install hangs when loading 8139too.o module
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-24 17:35 UTC by D. Hugh Redelmeier
Modified: 2007-04-18 16:32 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-09 17:05:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description D. Hugh Redelmeier 2001-04-24 17:35:29 UTC
When the installation tries to insmod 8139too.o on one of my systems, the
system hangs.

Hardware: AST Bravo MS P/100 Pentium 100, 32M RAM, ATAPI CDROM, Surecom
EP-320X-R RTL8139 NIC, integrated ATI Mach64 video controller, ...
Note that this hardware is happily running RHL6.2.

I've tried a network install.  Since the rtl8129 driver isn't on the
bootnet disk, I need to feed it the driver disk.  It hangs right after the
following appears on the ALT-F3 console:
	* going to insmod 8139too.o (path is /tmp/modules/8139too)

I've also tried a CDROM install.  It too hangs when installing this module,
but in this case it comes from the CDROM itself, not the driver disk.  In
this case the message reads:
	* going to insmod 8139too.o (path is NULL)
I haven't even needed the NIC in this install, but its module still gets
loaded.

When I remove the NIC and replace it with a Tulip-based card, installation
no longer hangs here (I haven't tried going farther yet).

When I try a Surecom card in another system (Celeron 700, i810 chipset),
installing the 8139too driver does not hang a bootnet install.

Comment 1 Brent Fox 2001-04-24 18:18:19 UTC
Sounds like the installer is doing the correct thing (trying to load the
module).  It looks like something's wrong with the driver, so I'm changing the
component to the kernel.  Thanks for your report.

Comment 2 Alan Cox 2003-06-09 17:05:13 UTC
Should have been resolved in the 7.x errata. If not please feel free to re-open


Comment 3 D. Hugh Redelmeier 2004-06-21 00:33:45 UTC
My name seems to have been forgotten.  I submitted this.


Note You need to log in before you can comment on or make changes to this bug.