Bug 37460 - Anaconda crashes with backtrace during upgrade from 7.0 to 7.1
Anaconda crashes with backtrace during upgrade from 7.0 to 7.1
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-24 14:18 EDT by Peter H. Jones
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-24 19:38:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda dump (1.14 KB, text/plain)
2001-04-24 14:19 EDT, Peter H. Jones
no flags Details

  None (edit)
Description Peter H. Jones 2001-04-24 14:18:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (Win98; U)


I attempted to upgrade from 7.0 to 7.1. During the installation process, anaconda gave a dump.with the message:
OSError: [Errno 2] No such file or directory: '/tmp/isodir///seawolf-i386-disc2.iso'
I will include the dump anaconda gave me on a diskette. I was delighted to find I could read that diskette in Windows; that
fact should be metioned in the error message.

Reproducible: Didn't try
Steps to Reproduce:
1. Boot with boot.img diskette
2. Run install/upgrade with both CD images in a single extended DOS partition
3. Select upgrade
	

Actual Results:  Anaconda crashes, says to reboot.

I then found I couln't boot Windows from disk. I saw the letters "LI" on the screen, and the computer hung.

Rebooting with a Windows emergency diskette revealed the directory containing the iso images was badly corrupted. As I had used a 
dedicated partition for the iso's, I was able to re-format that partition and copy from other unscathed Windows partitions.

Rebooting with the boot.img,I typed "linux rescue", then something like:
"cd /mnt/sysimage/etc
../sbin/lilo -r .."
After that, the machine could boot Windows. Probably Linux would work, too. Haven't tried yet.

Expected Results:  Installation of 7.1 system

Machine configuration can be provided if necessary. Looks like a coding glitch for now, though.
Comment 1 Peter H. Jones 2001-04-24 14:19:48 EDT
Created attachment 16267 [details]
Anaconda dump
Comment 2 Brent Fox 2001-04-24 14:35:22 EDT
Are you sure that the second disk images is in the right place?  The installer
can't seem to find it.
Comment 3 Peter H. Jones 2001-04-24 19:31:47 EDT
In fact, the first time I tried the upgrade, I had each disk image in a separate directory, and the installer stopped with a clear diagnostic within a few 
seconds of hitting "upgrade". I had hoped to get a chance to browse to the second image.

In response to the aforesaid diagnostic, I created a dedicated logical Windows partition large enough to contain both images, and copied both images 
into it. So, it seems I had both images in the same directory.

Because of the size of CD images, it would be desirable for the documentation to indicate whether or not it's a good idea to a) defragment and/or b) 
convert to 32-bit format, in Windows 98 and its successors.

I can no longer reproduce the problem, for I did a clean install.
Comment 4 Brent Fox 2001-04-24 19:38:04 EDT
Thanks for your report.
Comment 5 Peter H. Jones 2001-04-27 07:15:57 EDT
After doing the clean install, I tried again, wanting to test a Custom install, selecting Everything. To my surprise, the bug seemed to have returned! (I say 
"seemed" because I don't recall if the diagnostc message was the same or not.) Then, I remembered that, since my initial success, I had moved the CD 
images to a subdirectory named \RedHat\iso from the top level. When I moved these files back,  the install worked perfectly again.

I suspect the installer may not always read Windows 98 diretories correctly, especially if upper/lower case and/or long filenames are involved. Perhaps 
that would explain the intermittent file not found error.

I'm also having some trouble with the directory where I am trying to store the CD images. Because at least the both CD images for installing must be be 
in the same partition, I proactively allocated the remaining space on the disk as a single 2.7 GB partition with FDISK, and formatted it under Windows 98 
with the Disk Tools/Format Complete, which gives FAT16 format. I was hoping to store more than the minumum of 2 CD images with minimal 
fragmentation.  When I tried to convert to FAT32, Scandisk gave a message it could not handle the cluster size. Indeed, subsequent examination of trivial 
files on that partition revealed the cluster size chosen by Windows was  64K.

The Microsoft knowledge base artice Q127851, "Problems Accessing FAT16 Drives Larger Than 2 GB", at 
http://support.microsoft.com/support/kb/articles/q127/8/51.asp, recommends against partitions larger than 2GB in Windows 98, saying they cannot be 
accessed reliably. Specifically: "The size limit for logical drives using the FAT16 file system  in Windows 95/98 and MS-DOS is 2 GB." Unfortunately, 
FDISK didn't appear to enforce this limit, or give an warning message.

Since RedHat seems to be commited to using CD images for distributions, I suggest it provide documentation on efficient strategies for putting CD 
images on Windows98 partitions. On Windows 98, it appears possible to place them in groups of 3 on each 2GB partition; it would be useful to have 
exact partition sizes. I feel this information would encourage a large number of potential new users who are currently on Windows 98 to try RedHat 
Linux..

Here's a procedure I'd like to try next time around:
0. Strategically plan to make sure I'll be able to create the secondary partitions called for in Step 2..
1. Download a boot.img installation diskette from RedHAT and save to diskette.
2. Reboot with the Windows98 emergency diskette, and use FDISK to allocate a 5MB logical partition.
3. Instead of rebooting/reformattig with Windows98, boot from the installation diskette and use the FDISK/Disk Druid on it to create a FAT32
    file system on the partition created in Step 2.
4. CTRL-ALT-DEL to restart Windows 98 and download the CD images
5. Boot with the installation diskette and proceed with the installaion.
Comment 6 Peter H. Jones 2001-04-27 08:32:59 EDT
Oops:
Let's clarify Step 3:
3. Instead of rebooting/reformattig as prompted by  Windows98, boot from the RedHat boot.img installation diskette andUse Disk Druid/Fdisk to define
   the partition type as FAT32. After saving the new partition table, reboot (in Windows), and use the Format command in Windows to format the partition.
   (I'd have to try this to make sure it realy works.)

Fruther remarks:
Since, according to the Microsoft article,  the limit of 2GB is related to the 16 bits used to address the clusters on the disk, I speculate that cluster 
addresses wrap around, without this situation being detected by Windows. This wold explain why one CD iimage might appear to work, and another, with 
some of its clusters above 2GB, might not. It would also explain why I unexpectedly got a huge number of cross-linked files at one point on this disk,
and had to reformat and restore the CD images from backup copies. The restore would have placed both images below 2GB.

Conclusion: those reporting mysterious crashes, such as post-install hanging, or crashing for no good reason when installing from CD images should 
make sure these images can be validly read (specifically, they are not stored FAT16 on a partition larger than 2GB.)

I think I can cosider this case really closed now, and not just abandoned.
Comment 7 Brent Fox 2001-04-27 09:23:40 EDT
Hmm...I don't know.  The problem could be that *Windows 98* cannot reliably
access FAT16 volumes larger than 2GB...but Linux may have no trouble at all
accessing it.  I guess the question is, is there a fundamental limit to FAT16,
or is Windows' ability to access it broken?  I don't know.  Too bad we can't
look at the code and find out.  ;)

I'll test this out at work on my test machine if I get a chance.  Thanks for
your follow-up here.
Comment 8 Peter H. Jones 2001-04-27 15:03:57 EDT
The following might be of interest. I must admit I haven't tried downloading it yet, but I think it will tell if a download has succeeded. It's an md5sum for 
Windows, at: http://www.toast442.org/md5gui.shtml

From the description, I understand one could download a bunch of files and a file in the same directory containing the checksums (for convenience; it 
doesn't have to be there)and determine if the files are valid. I certainly want to try it; for it would save an indredible amount of mysterious problems caused 
by faulty downloads. With the program as-is, one could check readability under Windows, and on a dual-boot machine, check readability under RH Linux 
as you are proposing.

Perhaps a version could be compiled that would fit on a bootable diskette, making it possible to make sure installation/rescue files haven't been corrupted 
just before installation/rescue.
Comment 9 Peter H. Jones 2001-04-27 15:08:26 EDT
I tried the URL for downloading. Actually, the program is in the "pub" directory, so the correct URL is:
ftp://www.toast442.org/pub/md5.exe
Comment 10 Peter H. Jones 2001-05-04 09:51:47 EDT
Instead of the MD5 program cited above, I tried version 1.1.0.14 of an MD5 program, found by searching for "MD5" on the PC platform, at 
http://download.com, and downloaded from: http://homepages.ihug.co.nz/~floydian/md5/.

The MD5SUM file from RedHat contains:
---------- start ----------
edc2d5e1ab6093e3d486cc38dc12511a  seawolf-i386-SRPMS.iso
596b1575773e88e066326f6741312a6f  seawolf-i386-disc1.iso
f27b912299572a542cd663b712444445  seawolf-i386-disc2.iso
59f3333435378fb1645700731c91bc54  seawolf-i386-powertools.iso
---------- end ----------
If downloaded in binary format, the file will be lacking carriage-return characters, and will appear to be all on one line if Notepad is used. Passing the 
program through EDIT and saving under a new name is one simple way to insert the missing carriage-returns.

The MD5 program cited above produced the following in DOS format:
---------- start ----------
b2fb5470156a3ab945c530b9b16e7576 *MD5SUM
596b1575773e88e066326f6741312a6f *seawolf-i386-disc1.iso
f27b912299572a542cd663b712444445 *seawolf-i386-disc2.iso
59f3333435378fb1645700731c91bc54 *seawolf-i386-powertools.iso
edc2d5e1ab6093e3d486cc38dc12511a *seawolf-i386-SRPMS.iso
---------- end ----------
Note the additional asterisks, and the files may not be in the same order. Because of the asterisks, the MD5SUM file from RedHat cannot be used 
directly by this program. The computed checksums are the same.

A Scandisk run produced:
---------- start ----------
2 927 951 872 octets sur disque
            0 octets dans des octes defectueux
      196 608 octets dans 3 dossiers
      131 072 octets dans 2 fichiers caches
2 661 810 176 octets dans 12 fichiers utilisateur
  265 814 016 octets disponibles sur le disque
       65 536 octets dams chaque unite d'allocation
       44 677 unites d'allocation sur le disque
        4 056 unites d'allocation disponibles
---------- end ----------
Note that this was transcribed manually from a French system; I have intentionally omitted the accents. The preceding outputs are edited, so overall 
statistics, such as number of files, or totals, will appear to be incorrect. The 64 KB clusters make it possible to fill the disk, even if greater than 2 GB.

The disk directory (some files edited out) contiained:
---------- start ----------

 Le volume dans le lecteur J est CDS
 Le numro de srie du volume est 14E0-3079
 Rpertoire de J:\RedHat\iso

.              <REP>        01-04-24  23:47 .
..             <REP>        01-04-24  23:47 ..
SEAWOL~1 ISO   668 551 168  01-04-09   0:07 seawolf-i386-disc2.iso
DIR      DIR             0  01-05-03  16:32 dir.dir
MD5SUM                 233  01-04-15  20:19 MD5SUM
SEAWOL~2 ISO   672 518 144  01-04-09   0:06 seawolf-i386-disc1.iso
SEAWOL~3 ISO   678 244 352  01-04-09   0:08 seawolf-i386-SRPMS.iso
ISO      MD5           462  01-05-03  16:23 iso.md5
SEAWOL~4 ISO   641 806 336  01-03-05  17:33 seawolf-i386-powertools.iso
         7 fichier(s)      2 661 120 695 octets
         2 rpertoire(s)     265 814 016 octets libres
---------- end ----------
See remarks of Scandisk run, above.

Windows98 Issues:
1) When partitioning the disk with Windows 98 FDISK, the program prompted me to indicate whether I wanted large disk partitions (over 2GB). I 
answered in the affirmative. After rebooting under Windows, I formatted it under Windows98. 64KB clusters resulted, although Microsoft seems to claim 
the maximum cluster size is 32KB.

2) As stated by Microsoft, the partition cannot be defragmented; Defragmenter hangs, even if program optimization is disabled.

3) I cannot convert to FAT32 under Windows. When I try, the converter's normal procedure eventually has me restart Windows. As Windows reboots, I 
get the blue screen ScanDisk saying ScanDisk cannot handle the block size.

Conclusions:
1) Partitions larger than 2GB can be used under Windows 98 to accumulate CD images, but they cannot be defragmented, nor scanned at 
bootup. Perhaps Microsoft will issue an update someday.
2) It would be nice if RedHat made is possible to have CD images spread over more than one partition.

Note You need to log in before you can comment on or make changes to this bug.