Bug 374651 - kernel BUG at drivers/md/raid5.c:144!
kernel BUG at drivers/md/raid5.c:144!
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-10 09:05 EST by Joerg
Modified: 2007-12-07 18:34 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.6.23.8-34.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-07 18:34:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joerg 2007-11-10 09:05:53 EST
Description of problem:
I have an issue about Kernel 2.6.23.1-21.fc7.

The system has an md device made of four partitions (raid5). Ontop is lvm where 
I created a logical volume and put an ext3 filesystem on.

This raid has been created about one year ago.

When I read (cp, cat) a certain file in that filesystem the kernel triggers an 
kernel bug.

If I access the same file with 2.6.23.1-10.fc7 everythins works fine.


Version-Release number of selected component (if applicable):
2.6.23.1-21.fc7

How reproducible:
read file from filesystem

Steps to Reproduce:
1. cp fileA fileB

Actual results:
<0>------------[ cut here ]------------
<2>kernel BUG at drivers/md/raid5.c:144!
<0>invalid opcode: 0000 [#1]
<0>SMP
<4>Modules linked in: nfsd exportfs lockd nfs_acl auth_rpcgss autofs4 hidp 
l2cap bluetooth sunrpc ipv6 raid1 video output sbs battery ac via_ircc irda 
button crc_ccitt i2c_viapro e1000 i2c_core sg dm_snapshot dm_zero dm_mirror 
dm_mod ata_generic pata_via libata sd_mod scsi_mod raid456 async_xor 
async_memcpy async_tx xor ext3 jbd mbcache ehci_hcd ohci_hcd uhci_hcd
<0>CPU: 0
<0>EIP: 0060:[<df8c08c9>] Not tainted VLI
<0>EFLAGS: 00010002 (2.6.23.1-21.fc7 #1)
<0>EIP is at __release_stripe+0x96/0x117 [raid456]
<0>eax: 00000000 ebx: de70f840 ecx: 00000296 edx: de70f840
<0>esi: deeb4400 edi: de70f848 ebp: deeb44d4 esp: ded5af3c
<0>ds: 007b es: 007b fs: 00d8 gs: 0000 ss: 0068
<0>Process md3_raid5 (pid: 433, ti=ded5a000 task=def2d840 task.ti=ded5a000)
<0>Stack: 00000296 de70f840 deeb4400 00000296 df8c096b deeb44d4 deeb4400 
de70f840
<0> 00000000 df8c59d2 7fffffff ded5afcc 00000000 c061b8a0 dee81000 00000000
<0> dee6afa0 00000246 00000200 7fffffff ded5afcc 00000000 ded5af94 ded5afb8
<0>Call Trace:
<0> [<df8c096b>] release_stripe+0x21/0x2e [raid456]
<0> [<df8c59d2>] raid5d+0x397/0x39e [raid456]
<0> [phys_startup_32+-1084114784/-1073741824] schedule_timeout+0x13/0x8f
<0> [phys_startup_32+-1084639073/-1073741824] md_thread+0xb9/0xcf
<0> [phys_startup_32+-1086073915/-1073741824] autoremove_wake_function+0x0/0x35
<0> [phys_startup_32+-1084639258/-1073741824] md_thread+0x0/0xcf
<0> [phys_startup_32+-1086074114/-1073741824] kthread+0x38/0x5e
<0> [phys_startup_32+-1086074170/-1073741824] kthread+0x0/0x5e
<0> [phys_startup_32+-1086300741/-1073741824] kernel_thread_helper+0x7/0x10
<0> =======================
<0>Code: 80 c4 01 00 00 e8 f5 6f c2 e0 e9 86 00 00 00 90 0f ba 73 20 08 8d 4e 
38 8b 51 04 8d 43 08 e8 d0 64 c3 e0 eb 70 83 7a 34 00 74 04 <0f> 0b eb fe 90 0f 
ba 72 20 05 19 c0 85 c0 74 18 90 ff 4e 58 83
<0>EIP: [<df8c08c9>] __release_stripe+0x96/0x117 [raid456] SS:ESP 0068:ded5af3c

Expected results:
copy of file

Additional info:

If I access the same file with 2.6.23.1-10.fc7 everythins works fine.
Comment 1 Chuck Ebbert 2007-11-12 17:18:04 EST
This is probably due to a patch that got misapplied upstream, then copied into
Fedora. Can you try 2.6.23.1-28 (or later) when it is available?
Comment 2 Chuck Ebbert 2007-11-13 17:10:37 EST
2.6.23.1-28 submitted to updates-testing.

Note You need to log in before you can comment on or make changes to this bug.