This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 37467 - Machine hangs when loading X Module for S3 ProSavage KM133
Machine hangs when loading X Module for S3 ProSavage KM133
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-24 15:35 EDT by Craig Pennington
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-06 06:28:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
XF86Config-4 (3.64 KB, text/plain)
2001-04-26 10:25 EDT, Craig Pennington
no flags Details
XFree86.0.log (13.91 KB, text/plain)
2001-04-26 10:26 EDT, Craig Pennington
no flags Details
XFree86.0.log from working savage_drv.o 1.1.13 (from xfree86.org's upgrade release of 4.0.3) (19.90 KB, text/plain)
2001-04-26 10:54 EDT, Craig Pennington
no flags Details

  None (edit)
Description Craig Pennington 2001-04-24 15:35:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)


distributed savage_drv.o driver module hangs (do not pass go, do not write 
any output anywhere, just die) machine on K7VMA motherboard w/ VIA S3 
ProSavage KM133 video chipset

Reproducible: Always
Steps to Reproduce:
1. Install (on a machine w/K7VMA MB) through to X Configuration
2. Select any of the S3 drivers, & continue to mode selection
3. Test any video mode
	

Actual Results:  Screen goes blank -- no response from machine. I also 
tried finishing the install & booting to text mode, then running X while 
redirecting the output to a file, but the crash was so quick that the 
output file was not present after the subsequent fsck.

Expected Results:  valid X test.

I installed the linux binary of savage_drv.o from the generic XFree86 
4.0.3 update distro & was able to get X working with that. Has been up for 
the past 24+ hours.
Comment 1 Alexei Podtelezhnikov 2001-04-24 16:25:50 EDT
I believe that's what was fixed in Mike's 4.0.3-9 at 
ftp://people.redhat.com/mharris/xfree86/
Comment 2 Craig Pennington 2001-04-24 22:58:00 EDT
I tried the most recent savage driver (1.1.15) from 
<http://www.probo.com/timr/savage40.html> and the server from Mike's 4.0.3-9. 
Both hung the machine in the same way (requiring a hard reboot.)
Comment 3 Mike A. Harris 2001-04-25 01:34:45 EDT
Our 4.0.3-9 driver *is* the 1.1.15 driver from the URL you supplied.
It is the most stable Savage driver all around for now until the maintainer
finds solutions for the open bugs with it I'm afraid.  I've looked around
and can't find anything.  I do not have any hardware with which to test with
myself unfortunately.
Comment 4 Mike A. Harris 2001-04-25 01:36:36 EDT
Are you using Xconfigurator --preferxf4 to configure?

Please attach your X logs and configs below.
Comment 5 Craig Pennington 2001-04-26 10:25:34 EDT
Created attachment 16491 [details]
XF86Config-4
Comment 6 Craig Pennington 2001-04-26 10:26:39 EDT
Created attachment 16492 [details]
XFree86.0.log
Comment 7 Craig Pennington 2001-04-26 10:54:56 EDT
Created attachment 16493 [details]
XFree86.0.log from working savage_drv.o 1.1.13 (from xfree86.org's upgrade release of 4.0.3)
Comment 8 Craig Pennington 2001-04-26 10:57:44 EDT
I notice that the working version (1.1.13) INCORRECTLY identifies the video chipset as a PM133. I am very confident that the K7VMA in fact has the 
KM133.
Comment 9 NILMONI DEB 2001-07-05 13:28:38 EDT
I am currently using 4.1.0 with K7VMA motherboard (S3 ProSavage video) and facing the same problem of hung server when testing with Xconfigurator.
Comment 10 Mike A. Harris 2001-10-04 07:59:08 EDT
Please attach the output of "lspci -v" and also "lspci -vn" so I can
analize the PCI info to corelate with what XFree86 is doing.
Comment 11 Mike A. Harris 2001-10-27 18:06:00 EDT
Please supply the requested information.
Comment 12 Mike A. Harris 2001-11-06 06:27:23 EST
XFree86 4.1.0-5 contains the latest Savage driver, which includes
fixes for this chipset.  Others have reported that it solves problems
they were having.  Please try this, and give feedback of wether it
fixes the problem for you or not.  If not, then please supply the
information I have requested above.
Comment 13 Mike A. Harris 2001-11-06 06:28:00 EST
Oops, I left out the URL:

ftp://people.redhat.com/mharris/testing/bleeding-edge
Comment 14 Mike A. Harris 2002-06-19 12:52:45 EDT
Bug has remained in MODIFIED state with no problem report for over 6 months.
Closing bug as fixed in latest Savage driver in CURRENTRELEASE of Red Hat
Linux 7.3.

Note You need to log in before you can comment on or make changes to this bug.