Bug 37471 - set -o vi doesnt work
Summary: set -o vi doesnt work
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: bash   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-24 19:44 UTC by Need Real Name
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-24 19:44:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-04-24 19:44:55 UTC
If I include "set -o vi" into any start script such as /home/myaccount/.profile /home/myaccount/.bashrc /etc/bashrc /etc/profile vi is set and 
emacs is unset according to set -o
but the shell doesnt behave vi
After that I never get my vi-mode
Omitting set -o vi in any script I can get vi-mode by typing it into my interactive shell.

What can I do to get my vi-mode-shell automatically?

thx

martin

ps maybe not a bug but other systems I often handle behave as I assumed (set -o vi in /home/myaccount/.bashrc ... vi-mode in bash 1.14.7(1) 
on rh62 and bash 2.04.0(1) on a tru64-unix.

Comment 1 Bernhard Rosenkraenzer 2001-04-25 16:06:50 UTC
This is fixed in 2.05-1.



Comment 2 Beverly K. Pope 2001-05-07 11:25:11 UTC
I found a workaround that works beautifully for me in the gnu.bash.bug
newsgroup:

>From: stoll@deakin.edu.au (stoll@deakin.edu.au)
>Subject: RE: Can't pre-set "set -o vi" 
>Date: 1999/11/24
...
>The solution is amazingly simple.  Just add these lines to your
>/etc/inputrc:

>  set editing-mode vi
>  set keymap vi

>The distributed /etc/inputrc is configured exclusively for emacs mode,
>and to that end they've made it impossible to set it to vi mode.  With
>these added lines, you can toggle between the two, and your default is
>vi mode.  What could be better!
...
>Angelika Stoll


Note You need to log in before you can comment on or make changes to this bug.