Bug 37472 - Pnews filexp warning message, inews permission error, inews->inn dependency
Pnews filexp warning message, inews permission error, inews->inn dependency
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: inn (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-24 15:45 EDT by Tim Mann
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-24 16:31:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Mann 2001-04-24 15:45:44 EDT
1) Pnews (the news posting program used by trn) prints the following
cryptic error message whenever used.  

/usr/bin/Pnews: /usr/lib/trn/filexp: No such file or directory
/usr/bin/Pnews: /usr/lib/trn/filexp: No such file or directory

The file "filexp" is not mentioned in the Pnews man page, and I really
don't know what it is supposed to contain.  This error seems to be
nonfatal.

2) Pnews fails to work because /usr/bin/inews is not runnable by ordinary
mortals.

-r-xr-x---    1 root     system      51068 Feb 14 07:12 /usr/bin/inews

I don't know if there is a security reason for this.  Changing the
permissions to 555 as they were in RH7.0 makes Pnews get further.

3) After changing the permissions, inews does not work, even to post news
to a remote NNTP server, unless the inn package is installed.  It dies with
the error "Cannot open /etc/news/inn.conf". It seems to me that there
should be no need to install the inn package unless you want to run your
own news server on your box.  Also note that the inews RPM does not have a
dependency on inn recorded.
Comment 1 Trond Eivind Glomsrxd 2001-04-24 15:52:46 EDT
trn isn't included in RHL 7.1, because of its restricted license.
Comment 2 Tim Mann 2001-04-24 16:26:15 EDT
OK, but aren't (2) and (3) still bugs in inews?  The inews-2.3.1-2 package *is*
included in RH7.1.
Comment 3 Trond Eivind Glomsrxd 2001-04-24 16:31:06 EDT
Switching components.
Comment 4 Florian La Roche 2002-04-08 09:31:49 EDT
Perms on inews are ok and it now requires inn.

Thanks,

Florian La Roche

Note You need to log in before you can comment on or make changes to this bug.