Bug 374741 - Review Request: libmowgli - An algorithm framework
Review Request: libmowgli - An algorithm framework
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Parag AN(पराग)
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-10 10:30 EST by Ralf Ertzinger
Modified: 2013-01-09 23:29 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-25 23:43:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
panemade: fedora‑review+
kevin: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Ralf Ertzinger 2007-11-10 10:30:18 EST
Spec URL: http://www.skytale.net/files/libmowgli/libmowgli.spec
SRPM URL: http://www.skytale.net/files/libmowgli/libmowgli-0.5.0-0.1.sky.src.rpm
Description:

mowgli is a development framework for C (like GLib), which provides high
performance and highly flexible algorithms. It can be used as a suppliment to
GLib (to add additional functions (dictionaries, hashes), or replace some of
the slow GLib list manipulation functions), or stand alone. It also provides a
powerful hook system and convenient logging for your code, as well as a high
performance block allocator.



Note to the reviewer:
The release number in the package does not match the release number in the changelog entry. rpmlint will complain about this. This is intentional, and will be synchronized once the package is approved.
The rationale behind this is that "pre-release" release numbers (0.1, 0.2...) can be used during the review, so that the final package can be released with a release number of 1.
Comment 1 Parag AN(पराग) 2007-11-13 05:44:21 EST
source url is not working.
I found its http://distfiles.atheme.org/libmowgli-0.5.0.tgz

rpmlint complained on SRPM

libmowgli.src: W: strange-permission libmowgli-0.5.0.tgz 0600
A file that you listed to include in your package has strange
permissions. Usually, a file should have 0644 permissions.

libmowgli.src: W: strange-permission libmowgli.spec 0600
A file that you listed to include in your package has strange
permissions. Usually, a file should have 0644 permissions.
Comment 2 Parag AN(पराग) 2007-11-13 05:57:36 EST
good to add examples to %doc

build.log showed many escape sequences printed but not evaluated. I think its
because of Makefile written in that way.
Dunno if its really needed to avoid this but it looks very complex output from
build.log
Comment 3 Ralf Ertzinger 2007-11-13 06:04:45 EST
Will add the examples to %doc in devel.

The escape sequences come from the build system used in libmowgli, because I
disabled SILENT in the .spec. The alternative would be an output without any
compiler/linker calls, which makes build failures hard to debug.
I agree that it looks ugly, but I see no easy way around that.

URL and file permissions will be fixed, too.
Comment 4 Ralf Ertzinger 2007-11-13 10:16:01 EST
New SRPM/spec available at http://www.skytale.net/files/libmowgli/
Comment 5 Parag AN(पराग) 2007-11-14 00:45:10 EST
license looks to me as MIT not BSD.
Comment 6 Ralf Ertzinger 2007-11-14 03:44:08 EST
Upstream says it's ISC, will fix.
Comment 7 Ralf Ertzinger 2007-11-16 11:28:09 EST
New SRPM/spec available at http://www.skytale.net/files/libmowgli/
Comment 8 Parag AN(पराग) 2007-11-19 01:14:07 EST
Review:
+ package builds in mock (development i386).
+ rpmlint is silent for SRPM and for RPM.
   with assuming you will import with correct changelog version.
+ source files match upstream url
b8ba57aa4c674765b0852b44798227cb  libmowgli-0.5.0.tgz
+ package meets naming and packaging guidelines.
+ specfile is properly named, is cleanly written
+ Spec file is written in American English.
+ Spec file is legible.
+ dist tag is present.
+ build root is correct.
+ license is open source-compatible.
+ License text is included in package.
+ BuildRequires are proper.
+ Compiler flags used correctly.
+ defattr usage is correct.
+ %clean is present.
+ package installed properly.
+ Macro use appears rather consistent.
+ Package contains code, not content.
+ no static libraries.
+ libmowgli.pc file present.
+ -devel subpackage exists.
+ no .la files.
+ no translations are available.
+ Does owns the directories it creates.
+ ldconfig scriptlets present.
+ no duplicates in %files.
+ file permissions are appropriate.
+ Package libmowgli-0.5.0-0.3.fc9 ->
  Provides: libmowgli.so.1
  Requires: libc.so.6 libc.so.6(GLIBC_2.0) libc.so.6(GLIBC_2.1.3)
libc.so.6(GLIBC_2.3) libc.so.6(GLIBC_2.3.2) libc.so.6(GLIBC_2.3.4)
libc.so.6(GLIBC_2.4) libdl.so.2 libdl.so.2(GLIBC_2.0) libdl.so.2(GLIBC_2.1)
libmowgli.so.1 rtld(GNU_HASH)
+ Package libmowgli-devel-0.5.0-0.3.fc9 ->
  Requires: libmowgli = 0.5.0-0.3.fc9 libmowgli.so.1 pkgconfig
+ Not a GUI App.
APPROVED.
Comment 9 Ralf Ertzinger 2007-11-19 02:57:43 EST
Thank you for taking the time to review this.

New Package CVS Request
=======================
Package Name: libmowgli
Short Description: An algorithm framework
Owners: ertzing
Branches: F-7 F-8
Cvsextras Commits: yes
Comment 10 Kevin Fenzi 2007-11-19 11:33:34 EST
cvs done.
Comment 11 Parag AN(पराग) 2007-11-25 23:43:56 EST
As, I can see package is now in rawhide so I guess there will be no issues in
closing this review now.
Comment 12 Kevin Fenzi 2008-01-16 01:40:07 EST
Any reason there are still no F-7 and F-8 builds? 
Comment 13 Ralf Corsepius 2008-01-16 02:09:25 EST
(In reply to comment #12)
> Any reason there are still no F-7 and F-8 builds? 

What? How comes that today's FC8 audacious update already depends on them?

# yum update
...  
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package audacious-libs.i386 0:1.4.5-1.fc8 set to be updated
--> Processing Dependency: libmowgli.so.1 for package: audacious-libs
--> Finished Dependency Resolution
Error: Missing Dependency: libmowgli.so.1 is needed by package audacious-libs
Comment 14 Ralf Ertzinger 2008-01-16 02:19:03 EST
libmowgli has not been pushed to stable for F-8 as it should
have been. My mistake, the push has been requested.
Comment 15 Ralf Corsepius 2008-01-16 02:42:45 EST
(In reply to comment #14)
> libmowgli has not been pushed to stable for F-8 as it should
> have been. My mistake, the push has been requested.

This only partially answers my question.

A bit stronger: How comes that a package with apparently broken deps could have
made it into the official updates?
Comment 16 Ralf Ertzinger 2008-01-16 02:49:00 EST
That I do not know, I requested the push for audacious/audacious-plugins into
stable. mcs (another dependency) was moved into updates-candidate along with it,
but libmowgli was not.

Note You need to log in before you can comment on or make changes to this bug.