Bug 37476 - cpio permissions when migrating root FS
cpio permissions when migrating root FS
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: cpio (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-24 16:14 EDT by Tim Clymo
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 10:50:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tim Clymo 2001-04-24 16:14:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686)


This is a really strange one,  so please bear with me while I try to
explain:
Clean install of RH7.1 to a combination of /boot (23Mb RAID1 split between
2 IDE partitions), / on single 5Gb IDE partition and 512Mb swap on another
IDE partition.

The intention was to convert / to reiserfs on multiple RAID1 partitions,
but to keep it simple, here is another way to recreate the cpio problem:

1) Create 7 new ide partitions (mine are /dev/hde10-16 sized 256m, 512m,
512m, 256m, 3g, 256m and 512m respectively)
2) Boot system into single user
3) mkfs -t ext2 on each of 7 new partitions
4) mkdir /newroot
5) add the following into /etc/fstab:
/dev/hde10              /newroot               ext2    defaults        0 0
/dev/hde11              /newroot/home           ext2    defaults        0 0
/dev/hde12              /newroot/opt            ext2    defaults        0 0
/dev/hde13              /newroot/tmp            ext2    defaults        0 0
/dev/hde14              /newroot/usr            ext2    defaults        0 0
/dev/hde15              /newroot/usr/local      ext2    defaults        0 0
/dev/hde16              /newroot/var            ext2    defaults        0 0
6) mount -a, mkdir /newroot/home,opt,tmp,usr and var. mount -a again and
mkdir /newroot/usr/local. mount -a one more time
7) chmod 777 /newroot/tmp, followed by chmod o+t /newroot/tmp
8) find / -xdev|cpio -pdmV /newroot

This is the odd bit - after the cpio has completed successfully, some of
the directory permissions under /newroot are wrong. Specifically, lib bin
and usr/bin are set to mode 700 whereas they should be the same as their
sources (ie mode 755). I haven't spotted any others which look wrong, but I
haven't actually looked too hard.

Even stranger - if instead I just create /newroot as a single filesystem
(on /dev/hde14) and do the find|cpio it works as expected.

This took a long time to work out because I was subsequently changing
/newroot/etc/fstab and lilo.conf to boot off the new directory structure
after which X wouldn't work (obviously gdm needs non-privileged execute
access to /usr/bin at least), but it was a long way from obvious and many
hours were spent looking for phantom X, md and reiserfs interference
issues.

I have no clue what may be causing this - find|cpio is something I've been
doing for a long time to do filesystem migrations. I guess it's more likely
to turn out to be a kernel issue given the fact that it works OK to a
single target partition/filesystem, but I've logged this under cpio for
starters



Reproducible: Always
Steps to Reproduce:
1. See description
2.
3.
Comment 1 Tim Clymo 2001-08-17 03:40:21 EDT
This is still broken in Roswell - can somebody take a look?
Comment 2 Bill Nottingham 2006-08-07 13:47:41 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 3 Bill Nottingham 2006-10-18 10:50:46 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.