Bug 37477 - SWAT will not run when XINETD is used
SWAT will not run when XINETD is used
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: xinetd (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-24 16:19 EDT by Need Real Name
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-24 16:19:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-04-24 16:19:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)


In versions 7.0 and 7.1, SWAT will not function.  This seems to be related 
to the move to XINETD.  All recommended work arounds posted have been 
tried.

Reproducible: Always
Steps to Reproduce:
1.Fresh install
2.verify SWAT is listed in /etc/services
3.verify that:
disable = no 
only_from = 127.0.0.1
are specified in /etc/xinetd.d/swat file.
3.verify HTTPD, SMB & SWAT are set to start automatically 
(/usr/sbin/ntsysv used to do this)
	

Actual Results:  SWAT not work with Red Hat 7.0 or 7.1 (Samba 2.06, 2.07 
or 2.2 tried)



I have not seen anyone in newgroups successfully resolve this issue.
Comment 1 Trond Eivind Glomsrxd 2001-04-24 16:36:44 EDT
It works here - you probably forgot to do "service xinetd reload", use
"localhost" in your web address (as opposed to your.name.com) or ran into some
other local configuration issue.

Note You need to log in before you can comment on or make changes to this bug.