Bug 3748 - gv can't display most PostScript
gv can't display most PostScript
Product: Red Hat Linux
Classification: Retired
Component: ghostscript (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: David Lawrence
Depends On:
  Show dependency treegraph
Reported: 1999-06-26 14:24 EDT by mas22
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 1999-07-29 12:01:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description mas22 1999-06-26 14:24:53 EDT
Ghostview on my system, as shipped with 6.0,
cannot display most PostScript files I have tried.
These file all displayed properly under ghostscript
shipped with RH 5.1.

 gv /usr/share/ghostscript/5.10/examples/alphabet.ps
produces the error message
Error: /invalidfont in findfont
Operand stack:
   (Palatino-Italic)   Font   (Palatino-Italic)   13894
(Palatino-Italic)   --nostringval--   (Palatino-Italic)
URWPalladioL-Ital   Helvetica-Oblique   NimbusSanL-ReguItal
Execution stack:
   %interp_exit   .runexec2   --nostringval--
--nostringval--   --nostringval--   2   %stopped_push
--nostringval--   2   3   %oparray_pop   --nostringval--
--nostringval--   false   1   %stopped_push   1   3
%oparray_pop   .runexec2   --nostringval--
--nostringval--   --nostringv
Comment 1 Derek Tattersall 1999-06-28 10:13:59 EDT
Did you upgrade from 5.1 to 6.0?  If you did, try to uninstall all the
tetex RPMs, then reinstall them from the Cd.  Then try your test case
again.  Please report back to Bugzilla an your success or lack
Comment 2 mas22 1999-06-29 00:18:59 EDT
Yes, I upgraded from 5.1 to 6.0.  I uninstalled all the teTeX
packages, and manually removed /usr/lib/texmf.  gv still produced
an error message.  Re-installing the packages:

still, gv produced an error.
If I unistall ghostscript, and revert to
then gv now works.

I take it this was not a reproducable example!  If so,
it may be a support issue, and not a bug.
Comment 3 Bill Nottingham 1999-06-29 11:55:59 EDT
what does 'chkfontpath --list` say?
Comment 4 mas22 1999-07-02 01:50:59 EDT
athens% chkfontpath --list
Current directories in font path:
1: /usr/X11R6/lib/X11/fonts/misc:unscaled
2: /usr/X11R6/lib/X11/fonts/75dpi:unscaled
3: /usr/X11R6/lib/X11/fonts/100dpi:unscaled
4: /usr/X11R6/lib/X11/fonts/misc
5: /usr/X11R6/lib/X11/fonts/Type1
6: /usr/X11R6/lib/X11/fonts/Speedo
Comment 5 Michael K. Johnson 1999-07-13 13:17:59 EDT
On another computer with gv-3.5.8-7, ghostscript-5.10-7, and
ghostscript-fonts-5.10-3, I cannot reproduce this problem.

Have you tried reverting to the new versions of gv, ghostscript,
and ghostscript-fonts after downgrading?  After upgrading, if
the problem does not go away, try "rpm -y ghostscript" and see
if it complains about the file /usr/share/ghostscript/5.10/Fontmap
Comment 6 Bill Nottingham 1999-07-13 16:26:59 EDT
run 'chkfontpath --add /usr/X11R6/lib/X11/fonts/75dpi'
and then:
/etc/rc.d/init.d/xfs restart

That should solve the problem.
Comment 7 mas22 1999-07-23 15:57:59 EDT
Adding /usr/X11R6/lib/X11/fonts/75dpi to the font path
had no effect.

The other suggestion, however, found the problem.
When I updated to 6.0 (via the CDROM), the package
urw-fonts-1.1-8 was not installed, and for some reason
this was not found when I ran rpm --verify.

Note You need to log in before you can comment on or make changes to this bug.