Bug 374881 - NetworkManager 0.7 breaks madwifi (and ath5k never worked)
NetworkManager 0.7 breaks madwifi (and ath5k never worked)
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
i686 Linux
low Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-11-10 12:56 EST by Giuseppe Castagna
Modified: 2008-05-01 05:57 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.7.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-01 05:57:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Giuseppe Castagna 2007-11-10 12:56:58 EST
Description of problem:

I have an Atheros card on a thinkpad X80. I used it with the madwifi driver
since ath5k never worked for me (it scans but cannot associate). But with
NM 0.7 also madwifi stops working, as the dhcp request are never answered. 
Notice that if I try to configure manually the card it does not work. The 
only solution is to disable Wireless in NM (by right-click on the icon) and then
  configure manually the device. Notice that a call to dhclient works if
NM has Wireless disabled (but not if it is enabled)
Comment 1 Giuseppe Castagna 2007-11-10 12:58:33 EST
I forgot to add that this holds true both with the latest stable version of
madwifi and with the today's SVN version

Comment 2 Jesse Buchanan 2007-11-18 18:56:29 EST
I have the same issue on a Thinkpad T60 with AR5418 (DHCP will never associate).
Interestingly enough, my configuration is different: I am using ndiswrapper on
the AR5418 card.
Comment 3 Giuseppe Castagna 2008-01-17 10:59:24 EST
Just a couple of precision. I have two thinkpad X40 (not X80, of course, it deos
not exists), and I just came back from a conference tour in the States and can
confirm that this problem persists with several different access points (hotel
and four different conference networks). So the problem is neither related to
the wifi-base (they were of different brands) nor to my laptop (unless both of
them have broken configurations).

The error message is usually this one:

Jan 13 03:36:09 mirto NetworkManager: <info>  Activation (wlan0/wireless):
association took too long, failing activation.
Comment 4 Giuseppe Castagna 2008-05-01 05:57:37 EDT
I close this bug since now ath5k and NM work.

Note You need to log in before you can comment on or make changes to this bug.