Bug 3749 - /usr/lib/sendmail-cf/ostype/linux.m4 accidently defines args for procmail
/usr/lib/sendmail-cf/ostype/linux.m4 accidently defines args for procmail
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: sendmail (Show other bugs)
6.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-06-26 14:36 EDT by caret
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-09-01 09:06:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description caret 1999-06-26 14:36:47 EDT
In /usr/lib/sendmail-cf/ostype/linux.m4, the definitions for
LOCAL_MAILER_FLAGS and LOCAL_MAILER_ARGS are supposedly
commented out, however, a `#' doesn't begin a comment in m4;
that is done with either a `divert(-1)' or a `dnl'.  The
result is that if you don't have a `MAILER(procmail)' in
your mc file, sendmail will try to invoke /bin/mail with
procmail's arguments.

The fix is to replace the `#'s with `dnl's.
Comment 1 leduc 1999-07-20 14:40:59 EDT
I have been having trouble with sendmail since I upgraded to 6.0.
Every now and then it wouldn't run.  I'd get: 431  0.0  0.0     0    0
?        Z    13:19   0:00 [sendmail <defunct>]

I couldn't kill it, nor restart sendmail.  I had to reboot.

This would allow me to send outgoing mail, but incoming would get:
fetchmail: reading message 35 of 54 (2643 octets) .fetchmail: SMTP
connect to localhost failed
fetchmail: SMTP transaction error while fetching from groke

I just edited the file as indicated, and then used linuxconf to
regenerate the sendmail.cf file.

Poof! All works.

I STRONGLY recommend that you put out  a new version of sendmail
immediately. I think it is positively negligent that you had a
solution, and have not supplied any relief to users.

Ryan
Comment 2 Jeff Johnson 1999-09-01 09:06:59 EDT
Fixed in sendmail-8.9.3-15.

Note You need to log in before you can comment on or make changes to this bug.