Bug 374901 - F-7 xorg.conf doesn't work, dual head (system-config-display doesn't generate a usable config. either)
F-7 xorg.conf doesn't work, dual head (system-config-display doesn't generate...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
9
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-10 13:04 EST by James Antill
Modified: 2009-01-20 07:49 EST (History)
6 users (show)

See Also:
Fixed In Version: xorg-x11-drv-ati-6.8.0-14.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-10 09:39:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg config. (3.51 KB, text/plain)
2007-11-10 13:04 EST, James Antill
no flags Details
/etc/X11/xorg.conf - nonfunctional dual-head configuration (1.56 KB, text/plain)
2007-11-13 14:35 EST, John Sullivan
no flags Details
/var/log/Xorg.0.log - output with errors from nonfunctional dual-head config (20.89 KB, text/plain)
2007-11-13 14:36 EST, John Sullivan
no flags Details
my one and only xorg.conf with polished device options (1.37 KB, text/plain)
2007-11-16 07:13 EST, Michal Žejdl
no flags Details
Xorg.0.log with xorg-x11-drv-ati-6.7.195-3.fc8 (error) (19.38 KB, text/plain)
2007-11-16 07:14 EST, Michal Žejdl
no flags Details
Xorg.0.log with xorg-x11-drv-ati-6.6.3-4.fc7 (ok) (82.72 KB, text/plain)
2007-11-16 07:18 EST, Michal Žejdl
no flags Details
Xorg.0.log with xorg-x11-drv-ati-6.7.196-1.fc8 (error) (19.38 KB, text/plain)
2007-11-29 02:23 EST, Michal Žejdl
no flags Details
Xorg.0.log with xorg-x11-drv-ati-6.7.196-5.fc8 (memory issue?) (76.43 KB, text/plain)
2008-01-04 02:40 EST, Michal Žejdl
no flags Details
current xorg.conf with dual head - manually edited (1.29 KB, text/plain)
2008-07-10 03:36 EDT, Ingo Schaefer
no flags Details

  None (edit)
Description James Antill 2007-11-10 13:04:08 EST
Description of problem:
 My dual head xorg.conf doesn't work at all with the F8 radeon/ati driver.
Downgrading to: 
xorg-x11-drv-ati(0:6.6.3-2.fc7).x86_64 worked.

Version-Release number of selected component (if applicable):

xorg-x11-drv-ati.x86_64                  6.7.195-3.fc8

How reproducible:
 Always

Additional info:
 system-config-display also doesn't generate a usable config. for dual head
(signle head config. works though).

lspci -v info:


01:00.0 VGA compatible controller: ATI Technologies Inc RV370 [Sapphire X550
Silent] (prog-if 00 [VGA])
        Subsystem: Diamond Multimedia Systems Unknown device 0430
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at d0000000 (32-bit, prefetchable) [size=256M]
        I/O ports at 2000 [size=256]
        Memory at e0210000 (32-bit, non-prefetchable) [size=64K]
        Expansion ROM at e0220000 [disabled] [size=128K]
        Capabilities: [50] Power Management version 2
        Capabilities: [58] Express Endpoint IRQ 0
        Capabilities: [80] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0
Enable-

01:00.1 Display controller: ATI Technologies Inc RV370 secondary [Sapphire X550
Silent]
        Subsystem: Diamond Multimedia Systems Unknown device 0431
        Flags: bus master, fast devsel, latency 0
        Memory at e0200000 (32-bit, non-prefetchable) [size=64K]
        Capabilities: [50] Power Management version 2
        Capabilities: [58] Express Endpoint IRQ 0
Comment 1 James Antill 2007-11-10 13:04:08 EST
Created attachment 254011 [details]
Xorg config.
Comment 2 Matěj Cepl 2007-11-12 11:30:25 EST
Can we get /var/log/Xorg.0.log as well, please?
Comment 3 James Antill 2007-11-12 12:08:47 EST
 It's gone now, so it'll take a while before I can regenerate the problem (this
is my main desktop). However off hand I remember it complained about the PCI
ids. From the current Fed-7 Xorg log:

(--) PCI:*(1:0:0) ATI Technologies Inc RV370 [Sapphire X550 Silent] rev 0, Mem @
0xd0000000/28, 0xe0210000/16, I/O @ 0x2000/8, BIOS @ 0xfffe0000/17
(--) PCI: (1:0:1) ATI Technologies Inc RV370 secondary [Sapphire X550 Silent]
rev 0, Mem @ 0xe0200000/16

...in the Fed-8 one, IIRC, the first line was still there but the second one
failed with "cannot use PCI 1:0:1, already in use" or something like that.
Comment 4 Matěj Cepl 2007-11-13 09:03:37 EST
OK, waiting on that log file. If I won't get any message from you in a month, I
will close down this bug. OK?
Comment 5 John Sullivan 2007-11-13 14:35:10 EST
Created attachment 257311 [details]
/etc/X11/xorg.conf - nonfunctional dual-head configuration
Comment 6 John Sullivan 2007-11-13 14:36:37 EST
Created attachment 257321 [details]
/var/log/Xorg.0.log - output with errors from nonfunctional dual-head config
Comment 7 John Sullivan 2007-11-13 14:36:56 EST
Oops - sorry, first time logging a bugzilla.  I accidentally added the xorg.conf
and Xorg.0.log files first.

This problem sounds very similar to one that I am experiencing -
system-config-display does not produce a functional xorg.conf for a dual-monitor
configuration.  I'm running F8 with a Radeon RV100 on a 32-bit x86 machine. 
Here is the output of lspci from my system:

01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV100 QY [Radeon
7000/VE] (prog-if 00 [VGA])
	Subsystem: ATI Technologies Inc Unknown device 1b8a
	Flags: stepping, 66MHz, medium devsel, IRQ 17
	Memory at f0000000 (32-bit, prefetchable) [size=128M]
	I/O ports at ec00 [size=256]
	Memory at ff8f0000 (32-bit, non-prefetchable) [size=64K]
	Expansion ROM at ff800000 [disabled] [size=128K]
	Capabilities: [58] AGP version 2.0
	Capabilities: [50] Power Management version 2

I will attach the non-working dual-head /etc/X11/xorg.conf file as well as
/var/log/Xorg.0.log.

Thanks in advance for your help!
Comment 8 James Antill 2007-11-13 15:22:34 EST
 That looks like the same issue, as I tried without a BusID or Screen option too
(output of system-config-display) and it still didn't work.
 Currently I'm specifying both Screen (0) and BusID (identical to the other
device section) ... with the Fed-7 driver, which gave the slightly different
error message.
Comment 9 Michal Žejdl 2007-11-16 07:10:40 EST
I have the same problem with xorg-x11-drv-ati-6.7.195-3.fc8 and RV280 [Radeon
9200] on i386 machine. File Xorg.0.log ends with "Requested Entity already in
use!" too. Older xorg-x11-drv-ati-6.6.3-4.fc7 works fine. I'm using the same
xorg.conf as in F7.
Comment 10 Michal Žejdl 2007-11-16 07:13:04 EST
Created attachment 261071 [details]
my one and only xorg.conf with polished device options
Comment 11 Michal Žejdl 2007-11-16 07:14:50 EST
Created attachment 261081 [details]
Xorg.0.log with xorg-x11-drv-ati-6.7.195-3.fc8 (error)
Comment 12 Michal Žejdl 2007-11-16 07:18:28 EST
Created attachment 261091 [details]
Xorg.0.log with xorg-x11-drv-ati-6.6.3-4.fc7 (ok)
Comment 13 Michal Žejdl 2007-11-29 02:23:33 EST
Created attachment 272351 [details]
Xorg.0.log with xorg-x11-drv-ati-6.7.196-1.fc8 (error)

the error remains with latest update
Comment 14 James Antill 2007-12-21 12:54:40 EST
 I just tried the latest in updates-testing:

 xorg-x11-drv-ati.x86_64                  6.7.196-5.fc8

...this one booted up with dual head, and seemed like it might work ... but as
soon as I logged in Xorg crashed after starting some of the session. Also, when
I did C-A-F1 to reinstall the older rpm again, it locked the Video card up.
 So getting closer :).
Comment 15 Matěj Cepl 2008-01-03 17:59:07 EST
Could we get /var/log/Xorg.0.log again, please?
Comment 16 Michal Žejdl 2008-01-04 02:38:03 EST
Agree with #14. It started, but init 3 or reboot freezes system. On my dual head
1600x1200 and 1280x1024 it looks like there is memory sharing issue. On second
(smaller) head mouse pointer shows as bigger white-blue stripped box while on
first head appears a few black horizontal lines with white dots (probably arrow)
near bottom of the screen. Still unusable.
Comment 17 Michal Žejdl 2008-01-04 02:40:28 EST
Created attachment 290820 [details]
Xorg.0.log with xorg-x11-drv-ati-6.7.196-5.fc8 (memory issue?)
Comment 18 Matěj Cepl 2008-01-10 12:06:31 EST
James?
Comment 19 James Antill 2008-01-10 12:19:12 EST
I assume you want the non-working Xorg.0.log? I haven't updated/rebooted into
xorg-x11-drv-ati-6.7.196-5.fc8.x86_64 yet. I should get to it tomorrow, or the
weekend.
 If you just want an older working one, I can do that today.
Comment 20 Ingo Schaefer 2008-01-11 03:32:52 EST
Hi,

I can confirm this bug for i386, too.

Was using Fedora 7 since yesterday in working dualhead configuration, updated to
8 and had a cloned display after that. Fiddling around in config brought me no
success.

Seems the new drivers does not support Xinerama any more - a notice says one
should use RandR for this - but the RandR extension is not loaded by default and
can not be configured in xorg.conf afaik.

I turned by xorg-x11-drv-ati package back to the fc7 version (from updates),
which worked fine.

Regards,
Ingo
Comment 21 James Antill 2008-07-09 21:56:31 EDT
 Ok, moving to Fed-9 as this has basically gotten much worse now as the old f7
drv-ati isn't compatible with the new X server in Fed-9.

 Now it _mostly_ seems to work, I get two screens however something seems to
think the screens are bigger than they are. From my working Fed-8 (using
xorg-x11-drv-ati.x86_64) xdpyinfo says:

screen #0:
  dimensions:    2560x1024 pixels (748x302 millimeters)
  resolution:    87x86 dots per inch
  depths (7):    24, 1, 4, 8, 15, 16, 32

...on the Fed-9 machine I get:

screen #0:
  dimensions:    2800x1200 pixels (764x302 millimeters)
  resolution:    93x101 dots per inch
  depths (7):    24, 1, 4, 8, 15, 16, 32

...which predictably gives me one of those an annoying HW virtual desktop.
Hopefully the last tweak needed to completely fix this is easy now.
Comment 22 James Antill 2008-07-09 22:00:25 EDT
 In case it matters:

Installed Packages
xorg-x11-apps.x86_64                     7.3-3.fc9              installed       
xorg-x11-drivers.x86_64                  7.3-4.fc9              installed       
[...]
xorg-x11-drv-ati.x86_64                  6.8.0-14.fc9           installed       
[...]
xorg-x11-filesystem.noarch               7.3-1.fc9              installed       
xorg-x11-font-utils.x86_64               1:7.2-4.fc9            installed       
[...]
xorg-x11-server-Xorg.x86_64              1.4.99.905-1.20080701. installed       
xorg-x11-server-common.x86_64            1.4.99.905-1.20080701. installed       
xorg-x11-server-utils.x86_64             7.4-1.fc9              installed       
[...]
xorg-x11-utils.x86_64                    7.4-1.fc9              installed       
[...]
Comment 23 Ingo Schaefer 2008-07-10 03:36:04 EDT
Created attachment 311455 [details]
current xorg.conf with dual head - manually edited
Comment 24 Ingo Schaefer 2008-07-10 03:37:34 EDT
I've attached my xorg.conf which I edited after generating it with
system-config-display in Fedora 9. 

Now I don't get this annoying too big virtual desktop anymore.

But the fedora tools should definately create a usable dual head configuration!
Comment 25 James Antill 2008-07-10 09:39:06 EDT
 Confirmed that manually putting the "Virtual" line in to match your highest
mode makes it all happy. I guess we can close this now, as unusably hard to
configure is kind of a known bug, I guess :).
Comment 26 Ingo Schaefer 2008-07-10 10:00:37 EDT
Please reopen the bug and assign it to system-config-display.

Reason: The tools to configure the display resolution should generate
configuration files that match this configuration. And not adding the
"Virtual"-lines for the current mode means not to generate the configuration the
user requested.

As a side-note: system-config-display is not able to parse this configuration.
gnome-display-properties crashes.
Comment 27 James Antill 2008-07-10 10:07:22 EDT
 It might be worth opening a new BZ, but it doesn't seem right to overload this
one for that purpose ... this one was about the fact X would crash in dual head
mode, and that is now fixed in Fed-9.

 It's also worth nothing that, for me in Fed-9, system-config-display refuses to
output anything at all for dual head mode. Clicking the OK button didn't do
anything unless you de-selected dual head mode ... also when I first used dual
head mode, system-config-display was similarly non-functional.
 So this isn't a new/recent problem.

Note You need to log in before you can comment on or make changes to this bug.