Bug 374941 - Wrong label for FAT32 partition in fstab (don't know to which component this belows)
Wrong label for FAT32 partition in fstab (don't know to which component this ...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-10 13:29 EST by Sergio Cordeiro
Modified: 2008-04-22 10:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-22 10:40:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sergio Cordeiro 2007-11-10 13:29:26 EST
Hi

Sorry for posting this under the bootparamd, I don't know which component I
should have used.

The problem:
In F8 installation, if I tell the Anaconda installer to mount an existing FAT32
partition, it will use a label (label=/mnt/fat) instead of using /dev/sdX. 

After installing F8, this causes an error upon booting the PC which I solved by
replacing "label=/mnt/fat" with "/dev/sdX".

Thanks!
Comment 1 Andrew Farris 2008-01-10 06:40:49 EST
The correct fix here would be to label your FAT32 partition and mount by label
since the ordering of the devices will not necessarily be determinant anymore
(as I understand), which is why it is supposed to be choosing mount by label. 
The /dev/sdX is not guaranteed to be the same X for that partition at all
reboots starting with F8 where all harddrive devices are moved from /dev/hdX to
/dev/sdX irregardless of scsi/ide.

I'm guessing the bug here is probably that Anaconda needs to label the partition
for you as well as setup fstab to mount by label, when an existing partition is
in place and is not yet labeled and is not being reformatted during install.
Comment 2 Chris Lumens 2008-04-22 10:40:46 EDT
This should be fixed in F9.  We're using UUIDs instead of labels throughout now.

Note You need to log in before you can comment on or make changes to this bug.