Bug 374961 - Cannot run software updater at always complains about another application accessing software information
Cannot run software updater at always complains about another application acc...
Status: CLOSED DUPLICATE of bug 374801
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
8
i686 Linux
low Severity urgent
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-10 13:33 EST by NILMONI DEB
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-10 16:06:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
software updater complaining about rpm db access (24.47 KB, image/gif)
2007-11-10 13:33 EST, NILMONI DEB
no flags Details

  None (edit)
Description NILMONI DEB 2007-11-10 13:33:27 EST
Description of problem:

As says in subject (please see attached image too). Clicking on retry button 
does not help. As a result it is impossible to run software update on this 
freshly installed and clean fc8 system. If its because another instance of the 
software updater tool is already running in the background, the error message 
should at least suggest something meaningful to the user.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:

Just launch software updater tool from KDE menu.
Comment 1 NILMONI DEB 2007-11-10 13:33:27 EST
Created attachment 254021 [details]
software updater complaining about rpm db access
Comment 2 NILMONI DEB 2007-11-10 13:47:47 EST
I actually had to manually kill the process ->

/usr/bin/python -tt /usr/libexec/yum-updatesd-helper --check ....

to allow a new instance of the software updater to start. After it did start 
fine, it now hangs during "retrieving software information". This hang happens 
for the software add/removal tool (package manager) as well. Something is 
really wrong with these tools since command-line rpm works fine.
Comment 3 NILMONI DEB 2007-11-10 14:35:15 EST
I disabled yum-updatesd in system-config-services and the problem still 
continues.
Comment 4 Andre Robatino 2007-11-10 15:37:17 EST
  The same problem exists with command-line yum.  (PID 2552 was
yum-updatesd-helper which also belongs to the yum-updatesd package.)  The
component for this bug should be changed from pirut to yum-updatesd.

Existing lock /var/run/yum.pid: another copy is running as pid 2552.
Another app is currently holding the yum lock; waiting for it to exit...
Another app is currently holding the yum lock; waiting for it to exit...
Another app is currently holding the yum lock; waiting for it to exit...
Another app is currently holding the yum lock; waiting for it to exit...
Another app is currently holding the yum lock; waiting for it to exit...
Another app is currently holding the yum lock; waiting for it to exit...
Another app is currently holding the yum lock; waiting for it to exit...

(over and over until yum-updatesd is kill'ed and yum-updatesd-helper is kill'ed
with -9, since nothing else works).
Comment 5 Andre Robatino 2007-11-10 15:39:51 EST
  Also please change the priority to high or urgent.  This even prevents using
yum or pirut from being used for updates, unless instructions are given
separately for killing the renegade processes first, so just releasing updated
packages won't be enough.
Comment 6 Andre Robatino 2007-11-10 15:52:06 EST
  This appears to be a duplicate of bug #374801.
Comment 7 NILMONI DEB 2007-11-10 15:58:37 EST
After stopping the yum-updatesd thru system-config-services, neither 
the software update or install/removal tool would start initially. They would 
complain about another process accessing the software db. However, after 
waiting a long time (about an hour after stopping yum-updatesd) I could 
finally start the software install/removal tool but it got hung (just as 
described in comment 2).

For all practical purposes, fedora 8 should never have been released as a 
stable distro given its pre-alpha state of affairs.

(In reply to comment #5)
>   Also please change the priority to high or urgent.  

I don't think ordinary users (like me) can do that. I had already set the 
severity to urgent.

> This even prevents using
> yum or pirut from being used for updates, unless instructions are given
> separately for killing the renegade processes first, so just releasing 
updated
> packages won't be enough.

The problem created by yum-updatesd running at startup has been around for a 
year now (see http://forums.fedoraforum.org/showthread.php?t=142170 ) but at 
least on fedora 7, I could install/remove/update without problems. Fedora 8 is 
a step backwards.
Comment 8 NILMONI DEB 2007-11-10 15:59:00 EST
After stopping the yum-updatesd thru system-config-services, neither 
the software update or install/removal tool would start initially. They would 
complain about another process accessing the software db. However, after 
waiting a long time (about an hour after stopping yum-updatesd) I could 
finally start the software install/removal tool but it got hung (just as 
described in comment 2).

For all practical purposes, fedora 8 should never have been released as a 
stable distro given its pre-alpha state of affairs.

(In reply to comment #5)
>   Also please change the priority to high or urgent.  

I don't think ordinary users (like me) can do that. I had already set the 
severity to urgent.

> This even prevents using
> yum or pirut from being used for updates, unless instructions are given
> separately for killing the renegade processes first, so just releasing 
updated
> packages won't be enough.

The problem created by yum-updatesd running at startup has been around for a 
year now (see http://forums.fedoraforum.org/showthread.php?t=142170 ) but at 
least on fedora 7, I could install/remove/update without problems. Fedora 8 is 
a step backwards.
Comment 9 NILMONI DEB 2007-11-10 16:02:54 EST
Sorry for the double post, but the previous comments (6 and 7) collided and 
for some strange reason the bugzilla page started shaking abnormally (I am 
using kde/konqueror). I kept clicking and somehow managed to stop the shaking 
of the konqueror tab (no idea if this is a konqueror bug or a bugzilla 
problem).
Comment 10 James Antill 2007-11-10 16:06:46 EST

*** This bug has been marked as a duplicate of 374801 ***

*** This bug has been marked as a duplicate of 374801 ***

Note You need to log in before you can comment on or make changes to this bug.